Προς το περιεχόμενο

Αρχειοθετημένο

Αυτό το θέμα έχει αρχειοθετηθεί και είναι κλειστό για περαιτέρω απαντήσεις.

tarna

Πρόβλημε με ethernet router σε ubuntu 7.10

Προτεινόμενες αναρτήσεις

Κατα την διαρκεια της εγκαταστασης ηταν ολα οκ, ειχα ιντερνετ ενω γινοταν το Install, αλλα μετα το 1ο ρεσταρτ χαθηκε το ιντερνετ χωρις να αλλαξω καποιες ρυθμισεις. Μηπως μπορει καποιος να βοηθησει?

 

Εχω το sagem 1500WG συνδεδεμενο με ethernet cable και ενω ολα ειναι οκ σε windows σε ubuntu δε μπορω καν να δω το ρουτερ μου.

 

Τα settings μου ειναι στα windows ειναι:

 

IP Address: 192.168.2.2

Getaway: 192.168.2.1

Submask: 255.255.255.0

DNS Servers: 195.170.0.1

195.170.2.2

 

Στο ubuntu κανοντας ifconfig παιρνω:

 

eth0 Link encap:Ethernet HWaddr 00:19:66:08:FF:92

inet addr:192.168.2.2 Bcast:192.168.2.255 Mask:255.255.255.0

inet6 addr: fe80::219:66ff:fe08:ff92/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:0 errors:0 dropped:4294966871 overruns:0 frame:0

TX packets:0 errors:0 dropped:138 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

Interrupt:17

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0

inet6 addr: ::1/128 Scope:Host

UP LOOPBACK RUNNING MTU:16436 Metric:1

RX packets:47 errors:0 dropped:0 overruns:0 frame:0

TX packets:47 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:4297 (4.1 KB) TX bytes:4297 (4.1 KB)

 

Και στο ..../etc/network/interfaces

 

auto lo

 

iface lo inet loopback

 

 

iface eth0 inet static

address 192.168.2.2

netmask 255.255.255.0

gateway 192.168.2.1

 

 

auto eth0

 

 

 

Κάτι τελευταίο... στα ubuntu στο DNS servers έχω κανει add τα 195.170.0.1 195.170.2.2

 

Πατωντας στον firefox 192.168.2.1 δε μου ανοιγει τπτ....

Κατι τελευταιο, το φωτακι του ethernet μου αναβει, δλδ συμφωνα με το manual βρισκει δικτυο, αλλα δεν αναβοσβηνει αρα δεν "ανταλασσει πληροφοριες".

 

Αυτα... ελπιζω καποιος να μπορεσει να βοηθησει... μιας και ubuntu χωρις ιντερνετ....

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Έλεγξε τα εξής:

 

># sudo mii-tool eth0 |grep -i link
ή
# sudo ethtool eth0|grep -i link

 

># ping 192.168.2.1

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Δούλεψε φίλος! Σ'ευχαριστώ πολύ...

 

Αν έχει χρόνο εξήγησε μου τι ακριβώς έκανα. Απ'ότι κατάλαβα έκανα activate την σύνδεσή μου με το ρουτερ?

 

Thnx again

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Δεν έκανες καμία αλλαγή, και οι δύο εντολές ήταν διαγνωστικές. :confused:

 

Η mii-tool και η ethtool απλά ελέγχουν τα MII status codes της κάρτας δικτύου (αν υπάρχει σύνδεση σε επίπεδο ethernet).

 

H ping απλά στέλνει πακέτα ICMP type 8 ("echo request") σε μια διεύθυνση. Αν υπάρχει δίκτυο σε επίπεδο IP, θα πρέπει για κάθε "echo request" να επιστραφεί ένα "echo reply" από τον απομακρυσμένο host.

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Οκ thnx φιλος. Νταξ την Ping την ηξερα τι κανει. Αλλα οι αλλες τελειος καινουργιες για μενα. Ευχαριστω και παλι και κυριως που μου εξηγησες και τι ακριβως ηταν οι εντολες. Για να μαθαινουμε και σιγα σιγα :-D

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Μετα απο 2 μερες ξανα δεν μπορω να βρω ιντερνετ. Αν καποιος μπορει να βοηθησει ξανα...

 

Απο το τερματικο παιρνω τα εξης:

 

>
[email protected]:~$ sudo mii-tool eth0 |grep -i link
[sudo] password for tarna:
No MII transceiver present!.
[email protected]:~$ sudo ethtool eth0 |grep -i link
       Supported link modes:   10baseT/Half 10baseT/Full 
       Advertised link modes:  10baseT/Half 10baseT/Full 
       Link detected: yes


[email protected]:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:19:66:08:FF:92  
         inet addr:192.168.2.2  Bcast:192.168.2.255  Mask:255.255.255.0
         inet6 addr: fe80::219:66ff:fe08:ff92/64 Scope:Link
         UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
         RX packets:0 errors:0 dropped:4294967285 overruns:0 frame:0
         TX packets:0 errors:0 dropped:46 overruns:0 carrier:0
         collisions:0 txqueuelen:1000 
         RX bytes:0 (0.0   TX bytes:0 (0.0 
         Interrupt:17 

lo        Link encap:Local Loopback  
         inet addr:127.0.0.1  Mask:255.0.0.0
         inet6 addr: ::1/128 Scope:Host
         UP LOOPBACK RUNNING  MTU:16436  Metric:1
         RX packets:12 errors:0 dropped:0 overruns:0 frame:0
         TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:0 
         RX bytes:1076 (1.0 KB)  TX bytes:1076 (1.0 KB)

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

>
[email protected]:~$ sudo tracepath 64.233.187.99
1:  

Ο κερσορας αναβησβηνει μετα το 1 αλλα δεν κανει τπτ.

 

>[email protected]:~$ sudo traceroute 64.233.187.99
sudo: traceroute: command not found

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
×
×
  • Δημιουργία νέου...