Προς το περιεχόμενο

Αρχειοθετημένο

Αυτό το θέμα έχει αρχειοθετηθεί και είναι κλειστό για περαιτέρω απαντήσεις.

lamousis

RPC server is unavailable

Προτεινόμενες αναρτήσεις

Καλησπερα

 

Εχω ενα προβλημα με τα windows xp professional. Δε μπορουν να κανουν copy paste δε φοτωνει το driver της καρτας γραφικων δε μπορει να κανει εγκατασταση κανενος προγραμματος δε μπορει να δει το device manager και disk management

Σε ολα αυτα βγαζει το ιδιο error: "The RPC Server is unavailable"

 

Ξερει κανενας απο που μπορει να προερχεται αυτο;

Ψαχνοντας στο ιντερνετ βρηκα κατι προγραμματα τυπου registry fix αλλα τιποτα

 

Μπορει κανεις να βοηθησει;;;;

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Πηγαινε στο Control Panel/Administrative Tools/Services και δες αν το service 'Remote Procedure Call (RPC)' αρχιζει αυτοματα. Πρεπει να αρχιζει και να τρεχει αλλοιως τιποτα δεν θα δουλευει.

 

Αν ειναι σταματημενο, τσεκαρε το Event Log για λαθη.

Αν δεν μπορεις να μπεις στο Event Log, δοκιμασε απο Safe Mode η με καποιο boot CD που εχει το ERD Commander.

Απο τα λαθη, ισως καταλαβεις τι ειναι αυτο που δεν το αφηνει να αρχησει.

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Πρεπει να δωσεις κι'αλλες πληροφοριες μπας και βγει ακρη.

 

Πηγαινε στο Event Viewer, κανε right-click στο System, Applications και τα αλλα, και διαλεξε Clear All Events. Δεν χρειαζεται να τα σωσεις πουθενα.

 

Reboot το computer και δοκιμασε ενα copy/paste να δεις αν υπαρχει το προβλημα.

 

Πηγαινε παλι στο Event Viewer, κανε right-click το System (και αργοτερα το Applications) και κανε το Save σαν *.evt αρχειο. Θα καταληξεις με 2 αρχεια που τελειωνουν σε 'evt'.

 

Ανοιξε και το Administrative Tools/Services και κανε save την λιστα των services (Action/Export List). Απο εδω θα παρεις ενα *.txt αρχειο.

 

Βαλε τα 3 αρχεια στην απαντηση σου να ριξουμε μια ματια και βλεπουμε.

 

Υ.Γ. Ο λογος για το clear στην αρχη, ειναι για να μην ειναι μεγαλη η λιστα.

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

copy/paste δε κανει με τιποτα. την επιλογη paste την εχει σαν μη επιλεξιμη

 

Τα 3 αρχεια ειναι εδω

Desktop.zip

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Εχεις καμποσα παραξενα.

 

Το προβλημα ειναι κατω απο VMWare? Με αυτο κανεις boot η απλως φορτωνεις τα drivers? Αν ειναι με VMWare ισως καποιος να μπορει να βοηθησει καλυτερα γιατι εγω δεν το δουλεβω.

Αναφερομαι λοιπον σε αυτα που ξερω.

 

1. Οταν κανεις boot εχεις δυο errors στο Application Event Log.

 

Το ενα ειναι απο το Intel Application Accelerator. Αλλο απο το να το ανανεωσεις αν χρειαζεται δεν μπορεις να κανεις και πολλα. Το λαθος ισως να εχει σχεση με τα παρακατω.

 

Το δευτερο ειναι με τον Windows Explorer. Ειναι SP2 απ'οτι βλεπω αλλα το dbghelp.dll που καλει ειναι μεταγενεστερο. Βρες ολα τα dbghelp.dll στο PC σου και δες ποιο εχει το ιδιο version με το προβληματικο (v6.1.17.2). Απεγκαταστησε το προγραμμα που ηρθε με αυτο το DLL μπας και φταιει αυτο.

 

2. Εχεις και μερικα στο System log που αναφερονται σε προβληματα με το TCP/IP. Πιθανον κατι δεν παει καλα με το network setup του VMWare. Εδω χρειαζεσαι την βοηθεια αλλων.

 

3. Οι πιο πιθανοι λογοι για ολα τα προβληματα ειναι με τα Services του XP. Εχεις πειραξει μερικα απ'οτι φαινεται. Αλλαξε τα παρακατω σε πιο normal settings (ασχετως τι λεει ο Kelly και τα αλλα sites).

 

Alerter - automatic

COM+ Event System - automatic

COM+ System Application - automatic

SSDP Discovery Service - automatic

Volume Shadow Copy - automatic

 

Εχεις μερικα services που δειχνουν σαν 'starting'. Κακο αυτο και μαλλον φταιει για τα παραξενα. Η πιο πιθανη περιπτωση ειναι οτι εχει πειραχτει το DCOM configuration.

Το σχετικο service ειναι το 'DCOM Server Process Launcher'.

 

Σαν πρωτη προσπαθεια λοιπον δοκιμασε να διορθωσεις το DCOM.

Βαριεμαι να μεταφραζω τις σημειωσεις μου οποτε κανω attach τις οδηγιες στα Αγγλικα. Απλα ειναι αλλα αν κολλησεις ρωτα.

 

Θα δοκιμαζα αυτες τις οδηγιες πρωτα προτου πειραξω τιποτα αλλο. Δεν χαλανε τιποτα ετσι κι'αλλοιως.

 

Αν εισαι τυχερος, δοκιμασε τις 2 παρακατω εντολες πρωτα. Περιγραφονται και στο αρχειο που στελνω.

 

Ανοιξε ενα DOS παραθυρο στο C:\Windows\System32 και δωσε τις 2 εντολες¨

 

Regsvr32 ole32.dll

Regsvr32 oleaut32.dll

 

Καλη τυχη.

Reinstalling COM+ on Windows XP.zip

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
Εχεις καμποσα παραξενα.

 

Το προβλημα ειναι κατω απο VMWare? Με αυτο κανεις boot η απλως φορτωνεις τα drivers? Αν ειναι με VMWare ισως καποιος να μπορει να βοηθησει καλυτερα γιατι εγω δεν το δουλεβω.

Αναφερομαι λοιπον σε αυτα που ξερω.

 

1. Οταν κανεις boot εχεις δυο errors στο Application Event Log.

 

Το ενα ειναι απο το Intel Application Accelerator. Αλλο απο το να το ανανεωσεις αν χρειαζεται δεν μπορεις να κανεις και πολλα. Το λαθος ισως να εχει σχεση με τα παρακατω.

 

Το δευτερο ειναι με τον Windows Explorer. Ειναι SP2 απ'οτι βλεπω αλλα το dbghelp.dll που καλει ειναι μεταγενεστερο. Βρες ολα τα dbghelp.dll στο PC σου και δες ποιο εχει το ιδιο version με το προβληματικο (v6.1.17.2). Απεγκαταστησε το προγραμμα που ηρθε με αυτο το DLL μπας και φταιει αυτο.

 

2. Εχεις και μερικα στο System log που αναφερονται σε προβληματα με το TCP/IP. Πιθανον κατι δεν παει καλα με το network setup του VMWare. Εδω χρειαζεσαι την βοηθεια αλλων.

 

3. Οι πιο πιθανοι λογοι για ολα τα προβληματα ειναι με τα Services του XP. Εχεις πειραξει μερικα απ'οτι φαινεται. Αλλαξε τα παρακατω σε πιο normal settings (ασχετως τι λεει ο Kelly και τα αλλα sites).

 

Alerter - automatic

COM+ Event System - automatic

COM+ System Application - automatic

SSDP Discovery Service - automatic

Volume Shadow Copy - automatic

 

Εχεις μερικα services που δειχνουν σαν 'starting'. Κακο αυτο και μαλλον φταιει για τα παραξενα. Η πιο πιθανη περιπτωση ειναι οτι εχει πειραχτει το DCOM configuration.

Το σχετικο service ειναι το 'DCOM Server Process Launcher'.

 

Σαν πρωτη προσπαθεια λοιπον δοκιμασε να διορθωσεις το DCOM.

Βαριεμαι να μεταφραζω τις σημειωσεις μου οποτε κανω attach τις οδηγιες στα Αγγλικα. Απλα ειναι αλλα αν κολλησεις ρωτα.

 

Θα δοκιμαζα αυτες τις οδηγιες πρωτα προτου πειραξω τιποτα αλλο. Δεν χαλανε τιποτα ετσι κι'αλλοιως.

 

Αν εισαι τυχερος, δοκιμασε τις 2 παρακατω εντολες πρωτα. Περιγραφονται και στο αρχειο που στελνω.

 

Ανοιξε ενα DOS παραθυρο στο C:\Windows\System32 και δωσε τις 2 εντολες¨

 

Regsvr32 ole32.dll

Regsvr32 oleaut32.dll

 

Καλη τυχη.

 

 

Δυστυχως ουτε τωρα εγινε κατι. Δε το βλεπω να διορθωνεται το προβλημα!!

Απλως θελω να ρωτησω κατι τελευταιο:

Επειδη ο δισκος ειναι 2 δισκοι σε raid0, με ghost θα μπορεσω να σωσω τα αρχεια που εχει;

 

Ευχαριστω για τη βοηθεια

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Δεν ξερω για το Ghost αλλα σιγουρα κατι θα υπαρχει για Raid0 backup. Δεν δοκιμασα ποτε για να ξερω.

 

Εν τελει κανεις boot στο VMWare η οχι?

Δοκιμασες με boot στο κανονικο Windows? Safe Mode?

Ακολουθησες ολες τις οδηγιες στο αρχειο που εστειλα με τα απαραιτητα reboot σε Safe Mode κα Normal Mode? Δουλεψαν χωρις λαθος μηνυματα?

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
Εκανα οτι ελεγε το αρχειο αλλα δεν αλλξε τιποτα δυστυχως

 

Έκανα full update apo Windows Update και το πρόβλημα λύθηκε.

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Εχω το ιδιο προβλημα! ομως σε Windows 7...

 

Ολα μια χαρα χθες, το μονο που εκανα ηταν απεγκατασταση του Windows Live Messenger+ essentials

και στην θεση του εβαλα το Trillian Pro 4, το PC ηταν ανοιχτο το εκλεισα και σημερα που το ανοιξα

οποτε βαζω τον κωδικο μου για να μπω στα Windows, μου βγαζει RPC server is unavailable και κανει επανεκκινηση...

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
×
×
  • Δημιουργία νέου...