Προς το περιεχόμενο
tritonas00

Archlinux, απορια για πακετο

Προτεινόμενες αναρτήσεις

Μετα κοπων και βασανων εχτισα πακετα για αυτο και επειδης εχει ματωσει πολυς κοσμος να το χτισει στο arch (θελει gcc 4.5) και επειδης αυτο ειναι unstable  (επικοινωνησα με τον δημιουργο του που προσπαθουσε να χτισει stable version αλλα μου ειπε οτι παρεδωσε τα οπλα), σκεφτομαι να ανεβασω καπου τα πακετα για να τα παρετε οι του archlinuxgr repo να τα ανεβασετε (αμα θελετε  :P ) και να ανοιξω σχετικο thread στα forums του arch.
 
To πακετο ειναι το rigsofrods και εχει εξαρτησεις:
 
angelscript
boost-1.53
boost-libs-1.53
ogre-1.7.4
ogre-pagedgeometry
caelum-hg
mygui-svn
socketw
wxgtk2.9 (Community repo)

 

χτισμενες αναμεταξυ τους ομορφα και με τον ιδιο αρχαιο compiler.
 
Θα μπορουσα να παρω τις boost και boost-libs απο τα repos αλλα αν μεθαυριο γινουν update απο 1.53 σε what ever, αυτοματως εσπασε και το παιχνιδι (πρεπει να γινουν rebuild τα παντα against στην νεα boost - και εχει και θεματα ο linker και γαμσε με αναποδα.)

 

Οποτε εχτισα συγκεκριμενες εκδοσεις: boost-1.53 και boost-libs-1.53 οποιες κανουν conflict με τις boost και boost-libs του extra repo αλλα provides boost και boost-libs για τα αλλα προγραμματα που τις χρειαζονται.
 
Ετσι αυτα τα πακετα δεν γινονται ποτε update και το παιχνιδακι και οτιδηποτε αλλο τις χρειαζεται παιζει χαρωπα 
 
Θελω να ρωτησω το εξης:
 
Υπαρχει τροπος τα boost-1.53 και boost-libs-1.53 να χτιστουν ετσι ωστε να μπαινουν πλαι πλαι με τις boost και boost-libs του extra repo και να μην γινονται conflict τα αρχεια ? Οπως εχει γινει με αυτα πχ:
 
https://www.archlinux.org/packages/extra/i686/wxgtk/

https://www.archlinux.org/packages/community/i686/wxgtk2.9/
 
ωστε το παιχνιδι να τρεχει μονο με την boost-1.53 και boost-libs-1.53 και για το υπολοιπο συστημα να αναβαθμιζονται κανονικα οι boost και boost-libs ?

 

 

*Το παιχνιδι υπηρχε παλια στα repos του arch αλλα το εβγαλαν αφου ηταν πολυ δυσκολο να συντηρηθει.

*Αν και ανοιχτου κωδικα, το support για linux ειναι ΓΤΠ

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

βαλτα σε ενα vbox (αφου παρεις snapshoot) αφου αλλαξεις ονομα στα παλια σε κατι πχ boost-old και βγαζοντας απο το pkgbuild το conflict με την boost

δοκιμασε να χτισεις το παιχνιδι και αν ολα πανε καλα χτισε και κατι που θελει boost πχ xbmc

αν ολα πανε καλα ολα τα πακετα upload να μπουν στο ρεπο

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

βαλτα σε ενα vbox (αφου παρεις snapshoot) αφου αλλαξεις ονομα στα παλια σε κατι πχ boost-old και βγαζοντας απο το pkgbuild το conflict με την boost

δοκιμασε να χτισεις το παιχνιδι και αν ολα πανε καλα χτισε και κατι που θελει boost πχ xbmc

αν ολα πανε καλα ολα τα πακετα upload να μπουν στο ρεπο

 

Δεν σε επιασα. Ηδη εχω δημιουργησει πακετα με νεο ονομα: boost-1.53 και boost-libs-1.53 που conflicts/provides boost και boost-libs του repo.

 

Ειτε με το ενα ειτε με το αλλο χτιζονται οι εξαρτησεις και το παιχνιδι (το ιδιο πραμα ειναι στην ουσια)

 

απλα ρωταω πως και αν γινεται να εχουμε παραλληλα και τις 2 εκδοσεις των πακετων εγκατεστημενες χωρις να γινονται conflict τα αρχεια τους, ωστε το παιχνιδι να κατεβαζει και να παιζει με σταθερη boost και ολα τα υπολοιπα προγραμματα να παιρνουν κανονικα του extra repo.

 

:P

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

το boost1.53 & boost-libs1.53 δεν πρεπει να εχουν conflict στο pkgbuild με τα boost & boost-libs απο repo

το παιχνιδι πρεπει να εχει στο pkgbuild σαν depend τα boost1.53 & boost-libs1.53 

 

στο ίδιο vm που έχεις αυτά βάλε και τα κανονικά boost & boost-libs και χτίσε κάτι που θέλει boost

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

το boost1.53 & boost-libs1.53 δεν πρεπει να εχουν conflict στο pkgbuild με τα boost & boost-libs απο repo

 

Γιατι ? Αν μεθαυριο τα repos εχουν boost και boost-libs 1.54, χρειαζεται rebuild τα παντα, δεν θα ανοιγει το παιχνιδι.

 

το παιχνιδι πρεπει να εχει στο pkgbuild σαν depend τα boost1.53 & boost-libs1.53 

Ναι τα εχει και με αυτα χτιστηκε

 

στο ίδιο vm που έχεις αυτά βάλε και τα κανονικά boost & boost-libs και χτίσε κάτι που θέλει boost

 

Δεν μπορω να βαλω ταυτοχρονα boost boost-libs με boost1.53 boost-libs1.53

 

για αυτο ρωταω πως μπορει να γινει αυτο.

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Mπορει και να πω μαλακια τωρα...ειναι δυσκολη η ωρα..αλλα....αν ξηγηθεις links?

 

Δηλαδη τα πακετα ναναι boost1.53 boost-libs1.53 (αυτα που θελει το παιχνιδι)...και τα αλλα πακετα για ολα τα αλλα π.χ. boost1.54 boost-libs1.54

 

Τραβας 2 ln -s στα δευτερα ως boost / boost-libs :)

 

ΥΓ : οσο την επεξεργαζομαι την ιδεα νοιωθω οτι απο καπου μπαζει...αλλα ακομα δεν το εχω εντοπισει :)

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Γιατι ? Αν μεθαυριο τα repos εχουν boost και boost-libs 1.54, χρειαζεται rebuild τα παντα, δεν θα ανοιγει το παιχνιδι.

.

για να μπορει να συνυπάρχουν τα boost & boost1.53

.

Ναι τα εχει και με αυτα χτιστηκε

.

ok

 

Δεν μπορω να βαλω ταυτοχρονα boost boost-libs με boost1.53 boost-libs1.53

 

για αυτο ρωταω πως μπορει να γινει αυτο.

αν χτίσεις το boost1.53 χωρίς conflict με boost θα μπορεί να μπουν και τα δυο

 

για αυτό σου λέω θέλει test αν μπορούν να συνυπάρχουν ώστε να μην βγάζει το κανονικό boost γιατί θα σκάσουν άλλα πακέτα μετά πχ xbmc,deluge,ktorrent κτλ

 

Mπορει και να πω μαλακια τωρα...ειναι δυσκολη η ωρα..αλλα....αν ξηγηθεις links?

 

Δηλαδη τα πακετα ναναι boost1.53 boost-libs1.53 (αυτα που θελει το παιχνιδι)...και τα αλλα πακετα για ολα τα αλλα π.χ. boost1.54 boost-libs1.54

 

Τραβας 2 ln -s στα δευτερα ως boost / boost-libs :)

 

ΥΓ : οσο την επεξεργαζομαι την ιδεα νοιωθω οτι απο καπου μπαζει...αλλα ακομα δεν το εχω εντοπισει :)

δεν παίζει, θέλει το συγκεκριμένο που χτίστηκε το κάθε πακέτο

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

για να μπορει να συνυπάρχουν τα boost & boost1.53

 

Nop δεν μπορουν  συνυπαρξουν εχουν κοινα αρχεια.

 

Δηλαδη ο pacman μου βγαζει conflicting files και λογικο, τα 2 πακετα εχουν το ιδιο ακριβως περιεχομενο, το ονομα αλλαζει μονο.

 

Για αυτο θελω να τα διαχωρισω καπως απο την πηγη. Δηλαδη το boost1.53 αντι να βαζει τα αρχεια του στο /usr/include/boost/ , να τα βαζει στο /usr/include/boost1.53/ πχ

 

Αν γινει το παραπανω τοτε, ναι μπορω να αφαιρεσω το conflict με boost απο repo, να συνυπαρξουν, να χτισω το παιχνιδι με το νεο boost1.53 και παπαλα - να χρησιμοποιει αυτο αποκλειστικα.

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Nop δεν μπορουν  συνυπαρξουν εχουν κοινα αρχεια.

 

Δηλαδη ο pacman μου βγαζει conflicting files και λογικο, τα 2 πακετα εχουν το ιδιο ακριβως περιεχομενο, το ονομα αλλαζει μονο.

 

Για αυτο θελω να τα διαχωρισω καπως απο την πηγη. Δηλαδη το boost1.53 αντι να βαζει τα αρχεια του στο /usr/include/boost/ , να τα βαζει στο /usr/include/boost1.53/ πχ

 

Αν γινει το παραπανω τοτε, ναι μπορω να αφαιρεσω το conflict με boost απο repo, να συνυπαρξουν, να χτισω το παιχνιδι με το νεο boost1.53 και παπαλα - να χρησιμοποιει αυτο αποκλειστικα.

./configure --prefix=/opt \

--exec-prefix=/opt/bin \

etc \

etc

make

 

ακυρο, τωρα ειδα το pkgbuild

δεν εχει configure αλλα bootstrap αρα θα παιξεις με το install -d -m /opt/bin

  • Like 1

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Δηλαδη με το παραπανω οπου /usr θα ειναι /opt και τα εκτελεσιμα στο /opt/bin ?

 

ωραια θα το δοκιμασω και θα επανερθω, thanks!

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

να χτισεις τα 1.53 απο την αρχη και να πανε στο /opt και μετα στο pkgbuild του πακετου να τα ψαξει εκει περα..κατι τετοιο τελοσπαντων.

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Εγινε!

 

χρησιμοποιησα το /usr/local ομως οχι το /opt , για να την βρουν ευκολα οι υπολοιπες εξαρτησεις και να χτιστουν.

 

παω να χτισω τα του παιχνιδιου.

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
Δημοσ. (επεξεργασμένο)

Ολα ετοιμα (i686 προς ωρας)

 

Πλεον χτιστηκε και τρεχει χωρις boost και boost-libs οποτε ξεμπερδεψαμε απο κει. Oι νεες εξαρτησεις ειναι:

 

1.angelscript

2.poco

3.ogre1.7.4

4.mygui-svn

5.ogre-pagedgeometry

6.socketw

7.openal1.14

8.wxgtk

 

 

Τα 1,2,5,6 ειναι απο aur, δεν υπαρχουν στα main repos

Τα 3,4,7 κανουν conflict/provides με τα αντιστοιχα των repos 

Το 8 ειναι απο τα repos κανονικα

 

Κανω δοκιμες, παιζει καμπανα το παιχνιδι, θελω να δοκιμασω και στο netbook και σε vbox καθαρα αν ειναι ολα ok.

 

Eυχαριστω θερμα και τον tdev (εναν απο τους devs του παιχνιδιου)

Επεξ/σία από tritonas00

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Δημιουργήστε έναν λογαριασμό ή συνδεθείτε για να σχολιάσετε

Πρέπει να είστε μέλος για να αφήσετε σχόλιο

Δημιουργία λογαριασμού

Εγγραφείτε με νέο λογαριασμό στην κοινότητα μας. Είναι εύκολο!

Εγγραφείτε για έναν νέο λογαριασμό

Σύνδεση

Έχετε ήδη λογαριασμό; Συνδεθείτε εδώ.

Συνδεθείτε τώρα
×
×
  • Δημιουργία νέου...

Χρήσιμες πληροφορίες

Με την περιήγησή σας στο insomnia.gr, αποδέχεστε τη χρήση cookies που ενισχύουν σημαντικά την εμπειρία χρήσης.