Προς το περιεχόμενο
  • Εγγραφή

"κινεζικοι" υποτιτλοι στην tv, σωστοι στο mac?


JOHNNYSUEDE

Προτεινόμενες αναρτήσεις

Καλησπερα φορουμ….προσπαθω να μεταφερω απο το imac, μια ταινια που κατεβασα κ τους υποτιτλους της στο usb, ωστε να την δω στην τηλεοραση, αλλα οι υποτιτλοι εμφανιζονται κινεζικοι… Πως θα λυθει το προβλημα? Ευχαριστω

Συνδέστε για να σχολιάσετε
Κοινοποίηση σε άλλες σελίδες

Καλησπέρα. Να υποθέσω πως η ταινία είναι "τελευταίας κοπής"??? Αν ναι τότε μάλλον οι "κινέζικοι τίτλοι είναι ενσωματωμένοι στην ταινία. Για δοκίμασε τίτλους που κατέβασες και μάλλον θα δεις πως παίζουν κανονικά μαζί με τους (ενσωματωμένους) κινέζικους.

Συνδέστε για να σχολιάσετε
Κοινοποίηση σε άλλες σελίδες

Ετσι ακριβως….Απ'οτι βλεπω με μια αναζητηση στο γκουγκλ, θελει αλλαγη η κωδικοποιηση του υποτιτλου…Ετσι ειναι?

Ξερει κανεις πως γινεται?

Συνδέστε για να σχολιάσετε
Κοινοποίηση σε άλλες σελίδες

  • Moderators

Τα αρχεία ελληνικών υποτίτλων που κατεβάζουμε από το internet συνήθως χρησιμοποιούν για text encoding το ISO 8859-7 ή το (σχεδόν ίδιο) Windows-1253. Σπανιότερα, χρησιμοποιούν το UTF-8.

 

Οι περισσότεροι video players στο Mac (πχ το VLC) έχουν στις ρυθμίσεις τους επιλογή για το text encoding των υποτίτλων.

 

Μπορείς λοιπόν να δεις σε τι encoding είναι ρυθμισμένος ο Player στο Mac και (αφού με αυτή τη ρύθμιση παίζουν σωστά οι ελληνικοί υπότιτλοι που έχεις) να κάνεις την ίδια ρύθμιση στα μενού της τηλεόρασης σου.

 

Αν οι υπότιτλοι είναι σε ISO 8850-7 ή Windows-1253 και η τηλεόραση σου έχει μόνο επιλογή για UTF-8, μπορείς να κατεβάσεις το TextWrangler. Είναι πολύ καλός text editor (βασικά, είναι η δωρεάν έκδοση του BBEdit) και εκτός των άλλων επιτρέπει να δεις και να αλλάξεις το text encoding των αρχείων.

  • Like 1
Συνδέστε για να σχολιάσετε
Κοινοποίηση σε άλλες σελίδες

βρηκες λυση; ειχα παρομοιο προβλημα με μια LG τηλεοραση και τελικα αλλαξα το enconding των υποτιτλων απο την τηλεοραση χωρις να μπλεξω με το Mac.

Συνδέστε για να σχολιάσετε
Κοινοποίηση σε άλλες σελίδες

εγώ το ίδιο πρόβλημα σε mac mavericks, παίζει που το έχω σεταρι ως αμερικάνικο? με τα ελληνικα υπάρχει το πρόβλημα. 

 

Οπως αναφέρεται παραπάνω κατέβασε το VLC και άλλαξε εκεί το enconding των υποτίτλων για να παίξουν σωστά

Συνδέστε για να σχολιάσετε
Κοινοποίηση σε άλλες σελίδες

Οι περισσότερες τηλεοράσεις το θέλουν σε UTF8.

Εγώ σε Panasonic τηλεόραση σίγουρα αυτό ξέρω ότι είναι, και αλλάζει εύκολα απο το NotePad των windows. Ανοίξεις το .srt, πας File -> Save as -> UTF8 και τέλος.

 

Από ΟSX δεν έχει χρειαστεί να κάνω αλλαγή του encoding γιατί τα πάντα τα κατεβάζω από το κατεβαστήρι που είναι Windows...αλλά φαντάζομαι ένας απλός text editor κάνει την ίδια δουλειά. :)

 

Αυτό πάντως είναι, μην ψάχνεις αλλού για ρυθμίσεις κλπ, σώσε το αρχείο με encoding UTF8 και τελείωσες.


εγώ το ίδιο πρόβλημα σε mac mavericks, παίζει που το έχω σεταρι ως αμερικάνικο? με τα ελληνικα υπάρχει το πρόβλημα. 

 

Στη δική σου περίπτωση το πρόβλημα είναι στο encoding του VLC, βάλε στις ρυθμίσεις 1253 και είσαι οκ.

Στον παραπάνω φιλο αναφερόμουν στο θέμα της τηλεόρασης όπου τουλάχιστον οι Panasonic και οι Samsung που ξέρω δεν διαβάζουν αν δεν είναι UTF8.

Συνδέστε για να σχολιάσετε
Κοινοποίηση σε άλλες σελίδες

Και κάτω από το Mac OS είναι απλό να κάνεις την μετατροπή σε UTF-8

απλά άνοιξε τους υπότιτλους με το TextEdit μετά επιλέγεις

TextEdit -> Preferences και από το παράθυρο που σου ανοίγει επιλέγεις Open and Save

εκεί που λέει Saving Files διάλεξε Unicode(UTF-8)

και μετά File->Save

  • Like 1
Συνδέστε για να σχολιάσετε
Κοινοποίηση σε άλλες σελίδες

Δημιουργήστε ένα λογαριασμό ή συνδεθείτε για να σχολιάσετε

Πρέπει να είστε μέλος για να αφήσετε σχόλιο

Δημιουργία λογαριασμού

Εγγραφείτε με νέο λογαριασμό στην κοινότητα μας. Είναι πανεύκολο!

Δημιουργία νέου λογαριασμού

Σύνδεση

Έχετε ήδη λογαριασμό; Συνδεθείτε εδώ.

Συνδεθείτε τώρα
  • Δημιουργία νέου...

Με την περιήγησή σας στο insomnia.gr, αποδέχεστε τη χρήση cookies που ενισχύουν σημαντικά την εμπειρία χρήσης.