Προς το περιεχόμενο
Συνδεθείτε  
Hal9000

Τέλος στις μελλοντικές αναβαθμίσεις εφαρμογών του Android 2.3 Gingerbread και Honeycomb

Προτεινόμενες αναρτήσεις

Στο επίσημο blog που διατηρεί για τους προγραμματιστές της Android πλατφόρμας, η Google ανακοίνωσε ότι η δέκατη έκδοση του Google Play Services framework, θα είναι και η τελευταία που θα υποστηρίζει την έκδοση Gingerbread της πλατφόρμας όπως επίσης και την έκδοση 3.0 Honeycomb που είχε κυκλοφορήσει μόνο για tablets.

Η επόμενη έκδοση με αριθμό 10.2.0, θα υποστηρίζει σύμφωνα με την εταιρεία μόνο συσκευές που τρέχουν την έκδοση Android 4.0.1 Ice Cream και άνω, κάτι που θα συμβεί στις αρχές της επόμενης χρονιάς. Η κίνηση αυτή της Google αποτελεί και την ταφόπλακα σε μια από τις δημοφιλέστερες εκδόσεις του Android, η οποία μετρά ήδη 6 χρόνια ζωής, με το ποσοστό των ενεργών συσκευών που την υποστηρίζουν, να έχει πλέον περιοριστεί στο 1.3%.

 

Μετά από την εξέλιξη αυτή, οποιαδήποτε εφαρμογή κυκλοφορήσει στο Play Store της Google και η οποία κάνει χρήση μελλοντικών εκδόσεων του SDK, δε θα μπορεί να συνδεθεί με τα Google Play Services σε οποιαδήποτε συσκευή που στηρίζεται στην έκδοση Android 2.3 και 3.0, κάτι που θα καθιστά στην ουσία άχρηστη τη συσκευή για κάποιον που θα θέλει να αναβαθμίσει τις εφαρμογές και τα παιχνίδια του.

 

Link.png Site: Android Police

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Μάλιστα , αν και apple funboy δεν βρίσκω κάτι κακό εδώ... όλες οι εταιρίες το κάνουν αργά η γρήγορα.

  • Like 1

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Στην τελική έχουμε τα Custom Roms ή την εφαρμογή Aptoide ή βάζουμε manual τις εφαρμογές με apk αρχεία (σίγουρα μερικές από τις πιο πρόσφατες εφαρμογές δεν θα παίξουν στο Gingerbread!!)

 

Best Solution is custom rom !!!!!

  • Like 4

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Καιρός ήταν, 6 χρονών λειτουργικό και ήταν ακόμα στην αγορά. 

πω , πέρασαν 6 χρόνια  :fear:  πώς πέρασαν έτσι; 

  • Like 11

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Στην τελική έχουμε τα Custom Roms ή την εφαρμογή Aptoide ή βάζουμε manual τις εφαρμογές με apk αρχεία (σίγουρα μερικές από τις πιο πρόσφατες εφαρμογές δεν θα παίξουν στο Gingerbread!!)

 

Best Solution is custom rom !!!!!

Έλα για να το καταλάβεις καλύτερα

 

η οποία κάνει χρήση μελλοντικών εκδόσεων του SDK

 

SDK = Software Development Kit

 

Κάθε καινούργια έκδοση του Android SDK υποστηρίζει και τα προηγούμενα λειτουργικά. Άμα η Google εκδώσει καινούργιο SDK με καινούργια Features και αφαιρέσει την υποστήριξη των παλαιότερων λειτουργικών, δεν πά να βάλεις ότι θέλεις από customιές, άμα δεν τρέχει minimum ICS δεν πρόκειται να τρέξουν οι εφαρμογές. 

πω , πέρασαν 6 χρόνια  :fear:  πώς πέρασαν έτσι; 

Θυμάμαι ένα HTC που είχα με Gingerbread και αργότερα με ICS, ήταν και αυτές εποχές.

  • Like 2

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

htc desire με 2.2,ακόμα το εχω,ακόμα λειτουργει. <3

Εμένα HTC Desire S 2.3 παρέδωσε πνεύμα πριν 2 χρόνια.

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Έλα για να το καταλάβεις καλύτερα

 

η οποία κάνει χρήση μελλοντικών εκδόσεων του SDK

 

SDK = Software Development Kit

 

Κάθε καινούργια έκδοση του Android SDK υποστηρίζει και τα προηγούμενα λειτουργικά. Άμα η Google εκδώσει καινούργιο SDK με καινούργια Features και αφαιρέσει την υποστήριξη των παλαιότερων λειτουργικών, δεν πά να βάλεις ότι θέλεις από customιές, άμα δεν τρέχει minimum ICS δεν πρόκειται να τρέξουν οι εφαρμογές. 

Θυμάμαι ένα HTC που είχα με Gingerbread και αργότερα με ICS, ήταν και αυτές εποχές.

 

Mπορείς να βάλεις σε παλιότερες συσκευές custom rom με Android 4+ ,πχ στο Xperia X10 (οχι το mini) του 2009 έχει official μέχρι 2.3 και μπορείς με custom rom να βάλεις Android 4.2.2 - δεν θα είναι τόσο stable αλλά σίγουρα μπορείς να έχεις υποστήριξη ακόμη

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Mπορείς να βάλεις σε παλιότερες συσκευές custom rom με Android 4+ ,πχ στο Xperia X10 (οχι το mini) του 2009 έχει official μέχρι 2.3 και μπορείς με custom rom να βάλεις Android 4.2.2 - δεν θα είναι τόσο stable αλλά σίγουρα μπορείς να έχεις υποστήριξη ακόμη

Το θέμα είναι ότι οι περισσότερες ROM είναι προβληματικές, ελάχιστες είναι αυτές με καλή υποστήριξη όπως πχ η CM για τα Galaxy. Τώρα αν σοβαρά κάποιος κυκλοφορεί ακόμα με 8 χρονών κινητό και περιμένει να πάρει τις τελευταίες εφαρμογές τι να πω, καιρός να το αλλάξει :)

  • Like 3

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Η κίνηση αυτή της Google αποτελεί και την ταφόπλακα σε μια από τις δημοφιλέστερες εκδόσεις του Android, η οποία μετρά ήδη 6 χρόνια ζωής

...

Μετά από την εξέλιξη αυτή, οποιαδήποτε εφαρμογή κυκλοφορήσει στο Play Store της Google και η οποία κάνει χρήση μελλοντικών εκδόσεων του SDK, δε θα μπορεί να συνδεθεί με τα Google Play Services σε οποιαδήποτε συσκευή που στηρίζεται στην έκδοση Android 2.3 και 3.0, κάτι που θα καθιστά στην ουσία άχρηστη τη συσκευή για κάποιον που θα θέλει να αναβαθμίσει τις εφαρμογές και τα παιχνίδια του.

Για να θυμόμαστε

η Microsoft,

όταν διέκοψε την υποστήριξη των αναβαθμίσεων ασφαλείας των Windows XP

12+ χρόνια από την πρώτη κυκλοφορία τους,

κατηγορήθηκε πως το κάνει για να σπρώξει τους χρήστες σε νεότερες εκδόσεις

  • Like 3

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Για να θυμόμαστε

η Microsoft,

όταν διέκοψε την υποστήριξη των αναβαθμίσεων ασφαλείας των Windows XP

12+ χρόνια από την πρώτη κυκλοφορία τους,

κατηγορήθηκε πως το κάνει για να σπρώξει τους χρήστες σε νεότερες εκδόσεις

Κατηγορήθηκε λογικά από κλασσικούς κάφρους. Όταν έχουν βγει ειδικά για τα PC μετά τα XP άλλες 4 τουλάχιστον εκδόσεις (οκ κάνε τις 3 γιατί τα Vista ήταν γτπ :P) δεν υπάρχει λόγος να το υποστηρίζουν. Μάλιστα με την κυκλοφορία των 7 που ήταν από τις καλύτερες εκδόσεις των Windows πολλοί είχαν κάνει τότε την μετάβαση.

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Σκέψου με τη λήξη της υποστήριξης,

η Microsoft να έλεγε ότι τα exe θα σταματήσουν να τρέχουν στα Windows XP.

 

Και εν τω μεταξύ

είχε ήδη δώσει παρατάσεις στις αναβαθμίσεις ασφαλείας των XP

πέραν του αρχικού προγράμματος υποστήριξης.

 

Και παρ' όλα αυτά

το ίδιο βιολί με τις θεωρίες που ανακυκλώνονται σε πρώτη αφορμή

αρκεί ο πρωταγωνιστής να είναι η 'M$'.

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Σκέψου με τη λήξη της υποστήριξης,

η Microsoft να έλεγε ότι τα exe θα σταματήσουν να τρέχουν στα Windows XP.

 

Και εν τω μεταξύ

είχε ήδη δώσει παρατάσεις στις αναβαθμίσεις ασφαλείας των XP

πέραν του αρχικού προγράμματος υποστήριξης.

 

Και παρ' όλα αυτά

το ίδιο βιολί με τις θεωρίες που ανακυκλώνονται σε πρώτη αφορμή

αρκεί ο πρωταγωνιστής να είναι η 'M$'.

Καλά ναι και όμως πολλά προγράμματα δεν τρέχουν πλέον σε XP και δεν βρίσκω τον λόγο να τρέχουν. Όπως και να χει με τα Mobile λειτουργικά είναι λιγάκι διαφορετικά τα πράγματα αφού κάθε χρόνο βγαίνουν καινούργιες εκδόσεις.

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Καλά ναι και όμως πολλά προγράμματα δεν τρέχουν πλέον σε XP και δεν βρίσκω τον λόγο να τρέχουν. Όπως και να χει με τα Mobile λειτουργικά είναι λιγάκι διαφορετικά τα πράγματα αφού κάθε χρόνο βγαίνουν καινούργιες εκδόσεις.

Τα προγράμματα που δεν τρέχουν είναι κυρίως στην ευθύνη των δημιουργών προγραμματιστών.

Δε βγήκε ποτέ ας πουμε η 'M$' να κάνει μια παλιά έκδοση λειτουργικού να σταματήσει να τρεχει προγράμματα, ακόμα και τα συμβατά.

 

Όπως και να 'χει,

το θέμα με τα mobile λειτουργικά είναι πως ορισμένοι αιθεροβατούν στην ιδεα μήπως ποτέ ανταγωνιστούν τα desktop λειτουργικά

και με το συγκεκριμένο πλάνο υποστήριξης,

μια τέτοια εξέλιξη μόνο για καλό δε θα ήταν.

 

Άσε που η περιορισμένη αναβαθμισιμότητα-αναδρομική συμβατότητα των mobile λειτουργικών

είναι η ξεκάθαρη προσχεδιασμένη απαξίωσή τους για την οποία έχουν κατηγορηθεί ατυχώς τα XP και τα 7

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Δημιουργήστε έναν λογαριασμό ή συνδεθείτε για να σχολιάσετε

Πρέπει να είστε μέλος για να αφήσετε σχόλιο

Δημιουργία λογαριασμού

Εγγραφείτε με νέο λογαριασμό στην κοινότητα μας. Είναι εύκολο!

Εγγραφείτε για έναν νέο λογαριασμό

Σύνδεση

Έχετε ήδη λογαριασμό; Συνδεθείτε εδώ.

Συνδεθείτε τώρα
Συνδεθείτε  
×
×
  • Δημιουργία νέου...

Χρήσιμες πληροφορίες

Με την περιήγησή σας στο insomnia.gr, αποδέχεστε τη χρήση cookies που ενισχύουν σημαντικά την εμπειρία χρήσης.