Προς το περιεχόμενο
tasoylos

mikrotik load balance

Προτεινόμενες αναρτήσεις

Δημοσ. (επεξεργασμένο)

Καλησπερα παιδια 

Εχω ξεκινησει να κανω load balance με failover - PCC σε ενα mikrotik rb2011 και δεν μου το παιζει (τα δυο ρουτερακια ειναι τα speedport του ΟΤΕ)

To σεταρισμα εγινε απευθειας με κωδικα που γνωριζουμε οτι δουλευει σωστα 

Περα απο τα settings στο mikrotik πρεπει να γινουν και καποιες ενεργειες στα 2 router ?

Και θα μπορουμε να δωσουμε το output των 2 γραμμων σε παραπανω απο μια θυρα του router? 

ευχαριστω εκ των προτερων 

ΥΓ. Ο κωδικας ειναι αυτος 

# WAN1 network = 10.0.0.0
# WAN1 gateway = 10.0.0.1
#
# WAN2 network = 192.168.89.0
# WAN2 gateway = 192.168.89.1
#
# LAN network = 192.168.1.0
# LAN router IP = 192.168.1.1
#
/interface ethernet
set [ find default-name=ether3 ] name=LAN
set [ find default-name=ether1 ] name=WAN1
set [ find default-name=ether2 ] name=WAN2
/ip pool
add name=dhcp_pool1 ranges=192.168.1.2-192.168.1.254
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=LAN name=dhcp1
/ip address
add address=10.0.0.2/24 interface=WAN1 network=10.0.0.0
add address=192.168.89.254/24 interface=WAN2 network=192.168.89.0
add address=192.168.1.1/24 interface=LAN network=192.168.1.0
/ip dhcp-server network
add address=192.168.1.0/24 gateway=192.168.1.1
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
/ip firewall mangle
add action=mark-connection chain=input in-interface=WAN1 new-connection-mark=\
WAN1_conn passthrough=yes
add action=mark-connection chain=input in-interface=WAN2 new-connection-mark=\
WAN2_conn passthrough=yes
add action=mark-routing chain=output connection-mark=WAN1_conn \
new-routing-mark=to_WAN1 passthrough=yes
add action=mark-routing chain=output connection-mark=WAN2_conn \
new-routing-mark=to_WAN2 passthrough=yes
add action=accept chain=prerouting dst-address=10.0.0.0/24 in-interface=LAN
add action=accept chain=prerouting dst-address=192.168.89.0/24 in-interface=\
LAN
add action=mark-connection chain=prerouting dst-address-type=!local \
in-interface=LAN new-connection-mark=WAN1_conn passthrough=yes \
per-connection-classifier=both-addresses-and-ports:2/0
add action=mark-connection chain=prerouting dst-address-type=!local \
in-interface=LAN new-connection-mark=WAN2-conn passthrough=yes \
per-connection-classifier=both-addresses-and-ports:2/1
add action=mark-routing chain=prerouting connection-mark=WAN1_conn \
in-interface=LAN new-routing-mark=to_WAN1 passthrough=yes
add action=mark-routing chain=prerouting connection-mark=WAN2_conn \
in-interface=LAN new-routing-mark=to_WAN2 passthrough=yes
/ip firewall nat
add action=masquerade chain=srcnat out-interface=WAN1
add action=masquerade chain=srcnat out-interface=WAN2
/ip route
add check-gateway=ping distance=1 gateway=10.0.0.1 routing-mark=to_WAN1
add check-gateway=ping distance=1 gateway=192.168.89.1 routing-mark=to_WAN2
add check-gateway=ping distance=1 gateway=10.0.0.1
add check-gateway=ping distance=2 gateway=192.168.89.1
/system clock
set time-zone-name=Europe/Athens

Επεξ/σία από tasoylos

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
Δημοσ. (επεξεργασμένο)

πως το ξέρεις οτι δουλεύει σωστά, το διάβασες σε site ή το έχεις δοκιμάσει αλλού? Τι δεν σου δουλεύει, δεν βγαίνεις έξω, πεφτουν οι γραμμές και δεν γίνεται εναλλαγή ή δεν κάνει balance? Μπορείς να διαβάσεις το configuration σου ή όπως το βρήκες απο σελίδες το έβαλες, γιατι είναι πολύ κοινό config αυτό που βλέπω!

έτσι όπως δουλεύεις δεν θέλει κατι αλλο απο τα routers του ISP, αν και μπορείς να το κάνεις με άλλο τρόπο και να γλιτώσεις γραμμές κώδικα. Τέλος, βγαίνεις προς τα έξω τσεκάρωντας τα router του ΟΤΕ. εαν πέσει η γραμμή δεν θα σου δουλεύει νομίζω (εχω να χρησιμοποιήσω αυτή την μέθοδο 3 χρόνια και δεν θυμάμαι σίγουρα), μονο οταν χαθεί το ρούτερ θα σου κάνει αλλαγή.

 

νομίζω επίσης οτι δεν χρειάζεσαι στα routes distance οταν εχεις τα routing marks,

Επεξ/σία από mpentenis

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
Δημοσ. (επεξεργασμένο)

Δεν με βγάζει καθόλου έξω δηλαδη με πεταει σε unidentified Network στην lan 

Ο κωδικας ναι ειναι απο site και απο οτι λενε είναι σωστός

Δεν χρειάζεται δηλαδή να αλλαχτει το gateway απο τα 2 router ;

 

Επεξ/σία από tasoylos

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
Δημοσ. (επεξεργασμένο)

πρεπει και στα ρουτερ του οτε να βαλεις αντιστοιχα τις διευθύνσεις που εχεις στο mikrotik στις WAN1 & WAN2 .

τα ρουτερ του ΟΤΕ απο default εχουν 192.168.1.0/24

το configuration για το μικροτικ το βλεπω σωστο. πρεπει εσυ να βαλεις τις σωστες ip στα ρουτερ του οτε.

εγω PCC παιζω με pppoe client και οχι dhcp client που  πας να το κανεις εσυ.

Επεξ/σία από constantinos_rho

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
Δημοσ. (επεξεργασμένο)

στα 2 routers δεν αλλάζεις κάτι αφού παίζεις ως client τους, απλα έχεις καρφωτές διευθύνσεις (εννοείται οτι οι IPs σου είναι σωστές!)

Επίσης νομίζω οτι δεν χρειάζεσαι mark connection & routing στις εισερχόμενες αλλά μονο στις εξερχόμενες, υποψιάζομαι οτι στις μπερδεύει οποτε ακομα και αν βγείς εξω, balance δεν ξερω αν κάνει

Επεξ/σία από mpentenis

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
Δημοσ. (επεξεργασμένο)

πως δεν αλλαζει κατι? δε γινεται τα ρουτερ του οτε να ειναι και τα 2 στο ιδιο subnet 192.168.1.0/24

αυτο ειναι ενα παραδειγμα απο τα πολλα που κυκλοφορουν στο νετ που δειχνει οτι καθε WAN πρεπει να εχει αλλη IP.

/ip address
add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=LAN
add address=192.168.1.2/24 network=192.168.1.0 broadcast=192.168.1.255 interface=WAN1
add address=192.168.2.2/24 network=192.168.2.0 broadcast=192.168.2.255 interface=WAN2
add address=192.168.3.2/24 network=192.168.3.0 broadcast=192.168.3.255 interface=WAN3

Επεξ/σία από constantinos_rho

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Ωραια οποτε αλλαζω τις ip στα ρουτερ του οτε και ειμαι οκ

Στο θεμα της lan δεν μπορω να χρησιμοποιήσω και τις υπόλοιπες θύρες για το συνολο των ταχυτήτων;

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
Δημοσ. (επεξεργασμένο)

πρεπει να φτιαξεις μια BRIDGE και εκει να προσθεσεις τις πορτες ether3,ether4,ether5,ether6 κτλ.

εφοσο φτιαξεις την BRIDGE την ip πρεπει να τη δηλωσεις εκει και οχι στην ether3.

Επεξ/σία από constantinos_rho

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

1) βαλε τα 192.168.1.χ και 192.168.2.χ. Για τις θύρες πρέπει να κάνεις bridge ή να βάλεις ενα switch,αναλογα ποσες θες να έχεις πάνω. βάλε τις 6-10 μιας και ειναι 2011 οποτε όσες είναι δεξιά θα ειναι το ίδιο... IP θα βάλεις στο bridge οχι στην θύρα

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
Δημοσ. (επεξεργασμένο)

εγω βλεπω οτι την ether3 εχεις LAN

set [ find default-name=ether3 ] name=LAN

Επεξ/σία από constantinos_rho

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

set [ find default-name=ether3 ] name=LAN
set [ find default-name=ether1 ] name=WAN1
set [ find default-name=ether2 ] name=WAN2

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
Δημοσ. (επεξεργασμένο)

να φανταστω οτι παιζεις σε τελευταία εκδοση? 6.4x?

Επεξ/σία από constantinos_rho

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

πωω πωω συγνωμη παιδια 

Για καποιο λογο νομιζα οτι την ειχα στο 1 οποτε συνδεθηκα και στην 1 οταν εκανα την δοκιμη στη αρχη

costantinos_rho ευχαριστω πολυ για την προσφορα σου , αν δεν μπορεσω να συνεχισω θα το εκτιμουσα

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
Δημοσ. (επεξεργασμένο)

μη μας κανεις ομως τετοια lol.  οτι λες να ισχυει. τα καλωδια να ειναι σωστα συνδεμενα.

Επεξ/σία από constantinos_rho

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Δημιουργήστε έναν λογαριασμό ή συνδεθείτε για να σχολιάσετε

Πρέπει να είστε μέλος για να αφήσετε σχόλιο

Δημιουργία λογαριασμού

Εγγραφείτε με νέο λογαριασμό στην κοινότητα μας. Είναι εύκολο!

Εγγραφείτε για έναν νέο λογαριασμό

Σύνδεση

Έχετε ήδη λογαριασμό; Συνδεθείτε εδώ.

Συνδεθείτε τώρα
×
×
  • Δημιουργία νέου...

Χρήσιμες πληροφορίες

Με την περιήγησή σας στο insomnia.gr, αποδέχεστε τη χρήση cookies που ενισχύουν σημαντικά την εμπειρία χρήσης.