Προς το περιεχόμενο
Έλεος

Πρόβλημα με την εγκατάσταση Ubuntu (έχασα τα Windows;;;)

Προτεινόμενες αναρτήσεις

Καλησπέρα,

Ελπίζω να γράφω στη σωστή κατηγορία.

Έχω ένα Lenovo Ideapad 330s 15ARR (AMD), και αποφάσισα να του βάλω τα Ubuntu σε dual boot με τα Windows 10, που ήδη υπήρχαν, επειδή τα χρειάζομαι για την πτυχιακή μου.

Έφτιαξα ένα καινούριο partition στο C, και μετά από ψάξιμο και πολλές προσπάθειες λόγω ιδιαιτερότητας του συγκεκριμένου μοντέλου, κατάφερα να κάνω Install τα Ubuntu και πάτησα την επιλογή που έγραφε "Install Alongside another OS".

Στη συνέχεια έκανα restart και προς μεγάλη μου έκλπηξη στο Grub loader υπήρχαν μόνο τα Ubuntu και δύο επιλογές για "Windows Boot Manager" που όταν τις πατάω μου βγάζει αυτό:

IMG_20191005_233111.thumb.jpg.1981a4d3f832283ea378cbc47e65d295.jpg

Τι ακριβώς έκανα;; Να τα κλάψω τα Windows ή υπάρχουν ακόμα; Αν δεν υπάρχουν πως μπορώ να τα ξανακάνω install μιας και το laptop είχε έρθει με pre-installed Windows 10;

Ευχαριστώ 😥

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
14 λεπτά πριν, Έλεος είπε

Έφτιαξα ένα καινούριο partition στο C,

τι ακριβως εννοεις με αυτο;;

14 λεπτά πριν, Έλεος είπε

και μετά από ψάξιμο και πολλές προσπάθειες λόγω ιδιαιτερότητας του συγκεκριμένου μοντέλου, κατάφερα να κάνω Install τα Ubuntu και πάτησα την επιλογή που έγραφε "Install Alongside another OS".

αυτη η επιλογη συνηθως απλα κανει resize το ntfs partition των windows και βαζει στο τελος το linux

το θεμα ειναι τι εκανες και με τα αλλα λογικα partitions που εχουν τα win + το recovery partition που ουσιαστικα ειναι η εργοστασιακη εγκατασταση

μπες στο ubuntu τρεξε το gparted αν δεν το εχει

sudo apt-get install gparted

και θα δεις πως ειναι τωρα ο δισκος σου και πως ειναι τα partitions

αν δεν βγαλεις ακρη στειλε μια φωτογραφια απο το gparted

δοκιμασε το bios να το φερεις οπως ηταν με uefi και secure και δες τοτε αν κανει boot τα win

 

τωρα αν εσβησες τα win, θα τα κατεβασεις απο την microsoft και θα ενεργοποιηθουν μετα την εγκατασταση

 

  • Like 1

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Λογικα το recovery partition δεν το εχει σβησει , οποτε αν πατησει F1 μπορει να ξαναβαλει τα Windows της μανας του.

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
6 λεπτά πριν, xrhstosiak είπε

τι ακριβως εννοεις με αυτο;;

αυτη η επιλογη συνηθως απλα κανει resize το ntfs partition των windows και βαζει στο τελος το linux

το θεμα ειναι τι εκανες και με τα αλλα λογικα partitions που εχουν τα win + το recovery partition που ουσιαστικα ειναι η εργοστασιακη εγκατασταση

μπες στο ubuntu τρεξε το gparted αν δεν το εχει

sudo apt-get install gparted

και θα δεις πως ειναι τωρα ο δισκος σου και πως ειναι τα partitions

αν δεν βγαλεις ακρη στειλε μια φωτογραφια απο το gparted

δοκιμασε το bios να το φερεις οπως ηταν με uefi και secure και δες τοτε αν κανει boot τα win

τωρα αν εσβησες τα win, θα τα κατεβασεις απο την microsoft και θα ενεργοποιηθουν μετα την εγκατασταση

Όταν λέω ότι έφτιαξα καινούριο partition εννοώ ότι έκανα "Shrink" από τον C 35gb. Δεν είναι partition αυτό; :S

Το πρόβλημα είναι ότι όταν προσπαθώ να κάνω boot τα Ubuntu μου βγάζει μια μωβ οθόνη και κολλάει εκεί.

Στο GNU Grub οι μόνες επιλογές είναι αυτές:

  • Ubuntu (μωβ οθόνη)
  • Advanced Options for Ubuntu
  • Windows Boot Manager (on /dev/nvme01p2)
  • Windows Boot Manager (on /dev/sda1)
  • System Setup

Όταν πατάω τo "Advanced Options for Ubuntu" μου βγάζει 

  • Ubuntu, with Linux 5.0.0 - 13 - generic
  • Ubuntu, with Linux 5.0.0 - 13 - generic (recovery mode)

Όπου και στα 2 εμφανίζει μια μωβ οθόνη που γράφει

Loading Linux 5.0.0 - 13 - generic ...

Loading initial ramdisc ...

Αιώνιο loading screen και αυτό.

Το δοκίμασα και με UEFI & Secure και τζίφος...

3 λεπτά πριν, Talepwros είπε

Λογικα το recovery partition δεν το εχει σβησει , οποτε αν πατησει F1 μπορει να ξαναβαλει τα Windows της μανας του.

Δεν μου βγάζει επιλογή κάπου για F1. 😕

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
1 λεπτό πριν, Έλεος είπε

 

Δεν μου βγάζει επιλογή κάπου για F1. 😕

Στην εικονα απο τα windows που εβαλες δεν λεει πατα F1 για recovery  environment ;


Για να καταλαβω ουτε στο  Ubuntu μπαινει;
Καταλαβες κατα την εγκατασταση αν εκανες install στο "partition" που εφτιαξες ή αν η εγκατασταση Ubuntu εκανε resize το καινουργιο μικροτερο C ;

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
1 λεπτό πριν, Talepwros είπε

Στην εικονα απο τα windows που εβαλες δεν λεει πατα F1 για recovery  environment ;


Για να καταλαβω ουτε στο  Ubuntu μπαινει;
Καταλαβες κατα την εγκατασταση αν εκανες install στο "partition" που εφτιαξες ή αν η εγκατασταση Ubuntu εκανε resize το καινουργιο μικροτερο C ;

Α ναι έχεις δίκιο! Όταν πατάω F1 εκεί κάνει restart στο GNU GRUB πάλι.

Όχι ούτε στο Ubuntu μπαίνει.

Όταν έκανα εγκατάσταση πάτησα "Install alongside another OS" και δε με ρώτησε ποτέ σε πιο partition θα έκανε install και άρχισε την εγκατάσταση. 😕 

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Μπες με linux live usb, με το ubuntu που ίσως έχεις ή με κάποιο άλλο, τρέξε το gparted και δείξε μας την εικόνα, για να καταλάβουμε τι έχεις κάνει.

  • Like 1

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
8 λεπτά πριν, RTW4ever είπε

Μπες με linux live usb, με το ubuntu που ίσως έχεις ή με κάποιο άλλο, τρέξε το gparted και δείξε μας την εικόνα, για να καταλάβουμε τι έχεις κάνει.

Αμφιβαλω αν θα τα καταφερει, θα εχουμε παλι 8 σελιδες κουβεντα.

Προς ts για δοκιμασε αυτο για να ξανακανεις εγκατασταση τα windows.
 - Shut down the computer and wait at least five seconds. Press the Novo button to open the Novo Menu, then select System Recovery Troubleshoot Reset this PC.

To novo button φαινεται εδω, τερμα δεξια.
l_10180850_007.jpg

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
28 λεπτά πριν, RTW4ever είπε

Μπες με linux live usb, με το ubuntu που ίσως έχεις ή με κάποιο άλλο, τρέξε το gparted και δείξε μας την εικόνα, για να καταλάβουμε τι έχεις κάνει.

Έχω το Ubuntu 19.04 σε usb με το οποίο έκανα και την εγκατάσταση. Βάζω το Usb αλλά δεν βρίσκω πως να κάνω boot απο εκεί. Όταν βάζω μέσα από τα BIOS το USB πρώτο στο priority και κάνω restart, φορτώνει το GNU GRUB και όταν πάω στα BIOS το priority έχει χαθεί και το USB έχει πάει στο τέλος...

19 λεπτά πριν, Talepwros είπε

Αμφιβαλω αν θα τα καταφερει, θα εχουμε παλι 8 σελιδες κουβεντα.

Προς ts για δοκιμασε αυτο για να ξανακανεις εγκατασταση τα windows.
 - Shut down the computer and wait at least five seconds. Press the Novo button to open the Novo Menu, then select System Recovery Troubleshoot Reset this PC.

To novo button φαινεται εδω, τερμα δεξια.
l_10180850_007.jpg

Οι επιλογές του Novo button δεν κάνουν τίποτα πέρα απ'το να με στέλνουν είτε στο GNU GRUB είτε στο BIOS. Θεε μου τι έχω κάνει...

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
5 λεπτά πριν, Έλεος είπε

Έχω το Ubuntu 19.04 σε usb με το οποίο έκανα και την εγκατάσταση. Βάζω το Usb αλλά δεν βρίσκω πως να κάνω boot απο εκεί. Όταν βάζω μέσα από τα BIOS το USB πρώτο στο priority και κάνω restart, φορτώνει το GNU GRUB και όταν πάω στα BIOS το priority έχει χαθεί και το USB έχει πάει στο τέλος...

Κανεις save τις αλλαγες;;

5 λεπτά πριν, Έλεος είπε

Οι επιλογές του Novo button δεν κάνουν τίποτα πέρα απ'το να με στέλνουν είτε στο GNU GRUB είτε στο BIOS. Θεε μου τι έχω κάνει...

Τιποτα που να μην λυνεται :) 
Απλα εχεις πελαγωσει.

  • Thanks 1

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
1 λεπτό πριν, Talepwros είπε

Κανεις save τις αλλαγες;;

Τιποτα που να μην λυνεται :) 
Απλα εχεις πελαγωσει.

Εύχομαι να είναι όπως τα λες ρε συ επειδή ακούω άλλους που κάνουν brick τις συσκευές τους και με λούζει κρύος ιδρώτας! 😅

Όχι εντάξει αυτό ευτυχώς το κάνω σωστά Save&Exit. 😂

Έφτιαξα και ένα LiLi USB αλλά τζίφος και με αυτό... Δεν μπορώ να κάνω boot από το USB. 😕 

 

 

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
5 λεπτά πριν, Έλεος είπε

Έχω το Ubuntu 19.04 σε usb με το οποίο έκανα και την εγκατάσταση. Βάζω το Usb αλλά δεν βρίσκω πως να κάνω boot απο εκεί. Όταν βάζω μέσα από τα BIOS το USB πρώτο στο priority και κάνω restart, φορτώνει το GNU GRUB και όταν πάω στα BIOS το priority έχει χαθεί και το USB έχει πάει στο τέλος...

Οι επιλογές του Novo button δεν κάνουν τίποτα πέρα απ'το να με στέλνουν είτε στο GNU GRUB είτε στο BIOS. Θεε μου τι έχω κάνει...

Ψυχραιμία! Προφανώς εκεί στο "shrink" τα 'κανες μαντάρα, δεν μας είπες και πως το έκανες...

Προφανώς δεν κάνεις boot από το usb, για να σε πετάει στον grub. Μπες bios, μετά βρες την επιλογή load optimized defaults, μετά απενεργοποίησε secure boot. Ελπίζω το usb σου να είναι σε uefi mode. Αν είναι σε mbr mode, στο bios πρέπει να ενεργοποιήσεις και την επιλογή csm.

Μετά από τα παραπάνω, δοκίμασε ξανά boot με linux live usb.

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
11 ώρες πριν, RTW4ever είπε

Ψυχραιμία! Προφανώς εκεί στο "shrink" τα 'κανες μαντάρα, δεν μας είπες και πως το έκανες...

Προφανώς δεν κάνεις boot από το usb, για να σε πετάει στον grub. Μπες bios, μετά βρες την επιλογή load optimized defaults, μετά απενεργοποίησε secure boot. Ελπίζω το usb σου να είναι σε uefi mode. Αν είναι σε mbr mode, στο bios πρέπει να ενεργοποιήσεις και την επιλογή csm.

Μετά από τα παραπάνω, δοκίμασε ξανά boot με linux live usb.

Στο "shrink" πήγα στο Disk Management έκανα δεξί κλικ στο C, πάτησα Shrink, έγραψα 35000 όταν μου ζήτησε την αξία του μεγέθους και done. Μετά από αυτό τα Windows 10 έτρεχαν όπως πάντα δεν υπήρχε κάποιο θέμα.

Έκανα όσα μου είπες και δεν έχω κανένα αποτέλεσμα. Αδυνατεί να κάνει boot από το USB ότι ρύθμιση και να έχω δοκιμάσει στα BIOS. 😕 

 

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
Δημοσ. (επεξεργασμένο)

Update: έβαλα τα Windows στο USB με το MediaCreationTool και συνεχίζω να αντιμετωπίζω το ίδιο πρόβλημα... Δεν μπορώ να κάνω boot από USB... 

 

edit: Στα BIOS κάτω από το Security tab υπάρχουν και δύο επιλογές που λέγονται "Reset to Setup Mode" και "Restore Factory Keys". Να δοκιμάσω κάτι από αυτά; Δεν έχω ιδέα τι κάνουν...

Επεξ/σία από Έλεος

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

όχι μην τα πειράξεις, το ubuntu έχει υπογεγραμμένο image έτσι κι αλλιώς είναι compatible με UEFI.

  • Like 1

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Δημιουργήστε έναν λογαριασμό ή συνδεθείτε για να σχολιάσετε

Πρέπει να είστε μέλος για να αφήσετε σχόλιο

Δημιουργία λογαριασμού

Εγγραφείτε με νέο λογαριασμό στην κοινότητα μας. Είναι εύκολο!

Εγγραφείτε για έναν νέο λογαριασμό

Σύνδεση

Έχετε ήδη λογαριασμό; Συνδεθείτε εδώ.

Συνδεθείτε τώρα
×
×
  • Δημιουργία νέου...

Χρήσιμες πληροφορίες

Με την περιήγησή σας στο insomnia.gr, αποδέχεστε τη χρήση cookies που ενισχύουν σημαντικά την εμπειρία χρήσης.