Προς το περιεχόμενο
hexdec

Synology Diskstation 1513+ Array problem???

Προτεινόμενες αναρτήσεις

Καλησπέρα, είμαι κάτοχος ενος Synology Diskstation 1513+  το οποίο το δούλευα για 4 χρόνια με 2 δίσκους Seagate 4tb. Πριν απο 3 μήνες έκανα upgrade προσθέτοντας ακόμα 2 δίσκους πάλι seagate απο 4 tb ο καθένας και έκανα expand τησ συστοιχία. Όλα δούλευαν καλά μέχρι σήμερα. Άναψα το μηχάνημα και ενώ δούλευα σε κάποια αρχεία άρχισε να μην αποκρύνεται και να κάνει διαδοχικά beep. Δοκίμασα επανεκκινήσεις κτλ χωρίς αποτέλεσμα, το μηχάνημα δεν ηταν ορατό στο δίκτυο.

Ως τελευταία λύση αφαίρεσα τους δίσκους και έτρεξα το synology assistant, το οποίο το βρήκε εμφανίζοντας όμως "Configuration Lost" στο πεδίο status

Οι δίσκοι (2 παλίοι και 2 νέοι) ελέχθηκαν με τα seatools της Seagate και εμφάνισαν όλοι!! σφάλμα κατα τον έλεγχο του Smart...

Έχετε καμιά ιδέα τι μπορώ να κάνω για να σώσω την συστοιχία μου; Είναι δυνατόν και οι 4 δίσκοι να εμφανίζουν το ίδιο σφάλμα ταυτόχρονα;;

ΥΓ το synology έτρεχε πάντα πάνω σε UPS και γενικά δεν δούλευε πολύ καθώς χρησιμοποιούνταν περιοδικά για backup (2-3 φορες την εβδομαδα απο μερικές ώρες) αλλά και ως cloud storage για προσβαση στα δεδομένα μου απο αποσταση.... 

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Τα διαδοχικά beep αν δεν κάνω λάθος σημαίνει ότι κάποιος δίσκος από το array "χτύπησε" και σε προειδοποιεί για αντικατάσταση. Αλλά γιατί να μην εμφανίζεται το web interface του NAS δεν καταλαβαίνω - δεν σχετίζεται αυτό με το array. Σπάνια δίσκος παραδίδει το πνεύμα μονομιάς, το σύνηθες είναι να αρχίζει να εμφανίζει bad sectors.  Στη θέση σου θα δοκίμαζα να τα βάλω όλα όπως ήταν και θα κοιτούσα τι μου εμφανίζει στο disk health (έχει το Diskstation). Και στη συνέχεια εφόσον είναι εφικτό θα επιχειρούσα rebuild το array (αν χρειάζεται) για να πάρω backup τα δεδομένα.

Τέλος τι σφάλμα αναφέρει το Seatools για τον κάθε δίσκο και πως έχεις φτιάξει το array (raid?).

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
Δημοσ. (επεξεργασμένο)

Λοιπον, εχω νεότερα, εβαλα ενα ακομα δισκο ποιο μικρο, εκανα εγκατσασταση το dsm εσβησα το σύστημα, περασα και τους επιπλεον δισκους και μετα την εκκίνηση ειδα τα δεδομενα, τραβαω τωρα οτι δεν εχω backup.

Το προβλημα ειναι οτι και τωρα μου εμφανίζει  στο disk health partition failed για καποιο λογο...

Με Ta seatools ελεγξα ολους τους δισκους της συστοιχιας, ολα τα τεστ ειναι οκ εκτος απο το smart test που δινει fail στον καθε ενα.

Εβαλα τους δισκους και στο hdd sentinel αλλα εκει μου εμφανιζει οτι ολα ειναι ενταξει το ιδιο εμφανιζει και το crystal disk...

Με τους δίσκους της συστοιχιας πανω μονο δεν μπορω να συνθεθω πανω στο diskstation

Δεν μπορώ να καταλάβω τι γίνεται, ενημερώσεις στο dsm εκανα παντα κανονικα με την τελευταία να εχει πανω απο μηνα που έγινε...

Επεξ/σία από hexdec

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Τι ακριβώς σφάλμα σου βγάζει το seatools? Πάντως και τα άλλα δύο που αναφέρεις το SMART "διαβάζουν" οπότε κάποιο απ' αυτά τα εργαλεία δεν δίνει σωστή αναφορά. Το ευχάριστο είναι ότι διάβασες τα data σου και μπορείς να τα σώσεις. Όταν τελειώσεις δοκίμασε να ξαναστήσεις το array σου με τo αρχικό setup (4 δίσκοι) χρησιμοποιώντας το τελευταίο DSM και δες τι γίνεται.

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
3 ώρες πριν, TR-909 είπε

Τι ακριβώς σφάλμα σου βγάζει το seatools? Πάντως και τα άλλα δύο που αναφέρεις το SMART "διαβάζουν" οπότε κάποιο απ' αυτά τα εργαλεία δεν δίνει σωστή αναφορά. Το ευχάριστο είναι ότι διάβασες τα data σου και μπορείς να τα σώσεις. Όταν τελειώσεις δοκίμασε να ξαναστήσεις το array σου με τo αρχικό setup (4 δίσκοι) χρησιμοποιώντας το τελευταίο DSM και δες τι γίνεται.

Ενα smart test fail, το θεμα ειναι ποιο utility να εμπιστευτείς, της Seagate ή τα αλλα... 

Ενα άλλο θέμα που παρατηρησα ειναι οτι ενω εκανα μια νεα εγκατάσταση του dsm σε αλλο δισκο και διαβασα το array μετα απο καποιο χρονικό διάστημα (2 ωρες περίπου) χτυπησε και αυτή εμφανιζοντας την ιδια συμπεριφορά... Αρχίζω να υποψιάζομαι hardware προβλημα.

Ο επόμενος στοχος ειναι να αφήσω την νεα εγκατάσταση να λειτουργεί μονη της χωρις τους δίσκους του array και να δω τι θα κανει, περιμενω και το support της Synology να δω τι θα μου πουν...

5 δίσκοι με προβλημα ειναι απίθανο παντως...

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Οπότε όπως το καταλαβαίνω πλέον είναι ότι κάθε φορά που στήνεις DSM ανεξαρτήτως δίσκου, αυτό γίνεται corrupt μετά από κάποια ώρα χρήσης. Όντως περίεργο και εξειδικευμένο πρόβλημα. Το θεωρώ και εγώ απίθανο να προόκειται για θέμα των δίσκων - όλων τουλάχιστον. Ενδιαφέρον το τι θα σου πουν απο Synology.

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Τα νεότερα έχουν ως εξής:

Έστησα ξανά το DSM στον νεο δίσκο, και στην συνέχεια πέρασα το array που είχα, αυτή την φορά όμως έκανα Repair το array απο το Storage Manager πριν κάνω οτιδήποτε άλλο και δείχνει να έχει συνέλθει. Το έχω ανοικτό περίπου 3 ώρες και δουλεύει κανονικά. Η όλη ιστορία όμως μου έχει αφήσει μια περίεργη αίσθηση και δεν ξέρω αν θα μπορέσω να το εμπιστευτώ ξανά... Έβαλα ήδη επάνω ένα spare drive να βρίσκεται αλλά δεν ξέρω..., θα παρατηρήσω την συμπεριφορά του. 

Αυτή την στιγμή τραβάω το time machine σε ένα δίσκο απο το Synology που το είχα σαν δεύτερο backup...

H συστοιχία είναι σε μορφή Synology Hybrid Raid με fault tolerance και αυτό ίσως είναι ένα πρόβλημα καθώς δεσμεύομαι απο τα μηχανήματα της εταιρείας... Δεν ξέρω αν και πως γίνεται tranform σε άλλο Raid Type.

Κάτι ακόμα που με προβληματίζει είναι ότι τα εργαλεία της Seagate έβγαλαν σφάλμα και στους 4 δίσκους, είναι δυνατόν; To Smart Test απο το Diskstation δεν εμφανίζει κανένα πρόβλημα σε κανένα δίσκο και το Health Info είναι οκ σε όλους τους δίσκους, Λίγο επιπόλαιο δεν ήταν το partition failure που εμφάνισε; (ΝΑ ΣΗΜΕΙΩΣΩ ΌΤΙ ΠΟΤΕ ΔΕΝ ΈΧΕΙ ΤΕΡΜΑΤΙΣΕΙ ΚΑΤΑ ΤΗΝ ΔΙΑΡΚΕΙΑ ΠΟΥ ΠΕΡΝΑ ΔΕΔΟΜΕΝΑ ΚΑΘΩΣ ΤΟ Diskstation ΕΙΝΑΙ ΠΑΝΩ ΣΕ UPS)

Απο την Synology κανένα νέο αν και το ticket to δημιούργησα το Σάββατο το πρωί..... Μεγάλο φαουλ να μην κάνουν σωστό support απο ότι βλέπω

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Δεν έχω πείρα από Synology Hybrid Raid αλλά λογικά για να στήσεις ένα διαφορετικού τύπου array θα πρέπει να το φτιάξεις από το μηδέν  - δεν γνωρίζω τι ανάγκες έχεις, προσωπικά προτιμώ να "θυσιάσω" δίσκους στο βωμό του ανεκτού fault tolerance και των επιδόσεων (έως και 2 disk failures υπό προυποθέσεις στο Raid 10). Εδώ τουλάχιστον δείχνει πολύ περιορισμένες τις επιλογές για "μετατροπές":

Current RAID Type Possible Conversion Target Type Additional Number of Drives Required
Basic RAID 1 1
Basic RAID 5 2
RAID 1 RAID 5 1
RAID 5 RAID 6 1
SHR-1 SHR-2 1 or 2 (depending on the drive configuration of SHR)


(https://www.synology.com/en-global/knowledgebase/DSM/help/DSM/StorageManager/storage_pool_change_raid_type).

Το partition failure παραπέμπει είτε σε logical σφάλμα (πχ. file system corruption) ή σε "physical" (πχ. bad sectors). Σε κάθε περίπτωση και πριν πεις ότι μπορείς να εμπιστευτείς το NAS θα πρέπει να ελέγξεις τους δίσκους με λεπτομέρεια. Είναι άξιο απορίας πως το εργαλείο του κατασκευαστή (Seagate) δείχνει σφάλμα και τρία άλλα εργαλεία SMART δεν δείχνουν τίποτε - θα μπορούσες να κάνεις μια επικοινωνία με την Seagate (με screenshots) δίότι η λογική λέει πως ο κατασκευαστής γνωρίζει καλύτερα.

Για την Synology δοκίμασε και στο forum έχει καλά άτομα και γνώστες και σίγουρα θα πάρεις μια βοήθεια. Έως να σου απαντήσουν στο ticket.

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Το DSM είναι Linux, το Hybrid raid  (SHR) είναι mdraid+lvm+btrfs, με λίγη προσπάθεια μπορείς να κάνεις assemble το array σε ένα οποιοδήποτε Linux (για την περίπτωση που είχε χαλάσει τελείως το Synology). SHR-1 είναι mdraid-5 ενώ SHR-2 είναι mdraid-6.

 

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
Στις 3/5/2020 στις 9:54 ΜΜ, TR-909 είπε

Οπότε όπως το καταλαβαίνω πλέον είναι ότι κάθε φορά που στήνεις DSM ανεξαρτήτως δίσκου, αυτό γίνεται corrupt μετά από κάποια ώρα χρήσης. Όντως περίεργο και εξειδικευμένο πρόβλημα. Το θεωρώ και εγώ απίθανο να προόκειται για θέμα των δίσκων - όλων τουλάχιστον. Ενδιαφέρον το τι θα σου πουν απο Synology.

 Το SHR έχει 1 δίσκο redundancy και εύκολο expansion του array για αυτό το είχα επιλέξει, βέβαια κατόπιν το προβλήματος  που αντιμετώπισα θεωρώ ότι θα ήταν καλύτερη η λύση κανονικού RAID. Απλά δεν περίμενα ποτέ να βγάλουν σφάλμα ταυτόχρονα 4 δίσκοι (2 παλιοί και 2 3 μηνών).

Μετά απο δύο ημέρες απάντησαν απο την Synology. Αρχικά μου ανέφεραν ότι είναι hardware πρόβλημα της μονάδας, όταν τους έγραψα όμως ότι κατάφερα να την κάνω να λειτουργήσει μου ζήτησαν να πραγματοποιήσω μια σειρά απο διαγνωστικά τεστ και να ανεβάσω τα αποτελέσματα τους. Στο μεταξύ έχω κάνει data scrubbing σε όλους τους δίσκους της συστοιχίας το οποίο έλεγχο των δεδομένων με βάση το checksum χωρίς να βρεί κάποιο σφάλμα. Τώρα εκτελώ τα διαγνωστικά που ζήτησαν απο την εταιρεία (memory test + extendend smart test) αλλά υπολογίζω να χρειαστούν κανένα 24ωρο για να ολοκληρωθούν όλα.

Το θέμα με την Seagate και τα Sea Tools είναι όντως περίεργο και θεωρώ και εγώ δύσκολο να κάνει λάθος ο κατασκευαστής, αλλά στην φάση που είμαι για να ξανακάνω το τεστ θα πρέπει να βγάλω πάλι τους δίσκους απο το Synology, ίσως απο εβδομάδα να το δοκιμάσω...

 

8 ώρες πριν, malakudi είπε

Το DSM είναι Linux, το Hybrid raid  (SHR) είναι mdraid+lvm+btrfs, με λίγη προσπάθεια μπορείς να κάνεις assemble το array σε ένα οποιοδήποτε Linux (για την περίπτωση που είχε χαλάσει τελείως το Synology). SHR-1 είναι mdraid-5 ενώ SHR-2 είναι mdraid-6.

 

Ενδιαφέρουσα πληροφορία!, και έχω ένα μηχάνημα με στημένο Linux ίσως δοκιμάσω κάποια στιγμή να δω και εκεί την συστοιχία για να έχω την τεχνογνωσία έτοιμη σε κάθε περίπτωση... 

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Το synology και τα αντίστοιχα nas του είδους του δεν διαφέρουν σε πολλά από έναν υπολογιστή. Εγώ πιστεύω ότι έγινε corrupt το filesystem του array από δυσλειτουργία του τροφοδοτικου. Με την πρόσθεση δίσκων αύξησες το φορτίο του. Το ίδιο είχα πάθει και εγώ όταν είχα φτιάξει ένα είδος RAID στο pc με windows. Οι μπλε οθόνες ερχόντουσαν η μια μετά την άλλη. Με το που άλλαξα τροφοδοτικό τέλος όλα. Το μηχάνημα δουλεύει απροβλημάτιστα ένα χρόνο τώρα.

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Δεν αποκλειω κανενα ενδεχομενο, περιμενω το extended smart report, το οποιο θελει 30 ωρες για να ολοκληρωθει σε ολους τους δισκους...

3 ώρες πριν, atheatos είπε

Το synology και τα αντίστοιχα nas του είδους του δεν διαφέρουν σε πολλά από έναν υπολογιστή. Εγώ πιστεύω ότι έγινε corrupt το filesystem του array από δυσλειτουργία του τροφοδοτικου. Με την πρόσθεση δίσκων αύξησες το φορτίο του. Το ίδιο είχα πάθει και εγώ όταν είχα φτιάξει ένα είδος RAID στο pc με windows. Οι μπλε οθόνες ερχόντουσαν η μια μετά την άλλη. Με το που άλλαξα τροφοδοτικό τέλος όλα. Το μηχάνημα δουλεύει απροβλημάτιστα ένα χρόνο τώρα.

 

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Δημιουργήστε έναν λογαριασμό ή συνδεθείτε για να σχολιάσετε

Πρέπει να είστε μέλος για να αφήσετε σχόλιο

Δημιουργία λογαριασμού

Εγγραφείτε με νέο λογαριασμό στην κοινότητα μας. Είναι εύκολο!

Εγγραφείτε για έναν νέο λογαριασμό

Σύνδεση

Έχετε ήδη λογαριασμό; Συνδεθείτε εδώ.

Συνδεθείτε τώρα
×
×
  • Δημιουργία νέου...

Χρήσιμες πληροφορίες

Με την περιήγησή σας στο insomnia.gr, αποδέχεστε τη χρήση cookies που ενισχύουν σημαντικά την εμπειρία χρήσης.