Προς το περιεχόμενο

Αρχειοθετημένο

Αυτό το θέμα έχει αρχειοθετηθεί και είναι κλειστό για περαιτέρω απαντήσεις.

Cntrl+X

Πρόβλημα με GUI μετά από αναβάθμιση του kernel

Προτεινόμενες αναρτήσεις

Μετά από αναβάθμιση του πυρήνα (openSUSE Linux 10.3) δε σηκώνεται ο xserver. Το πρόβλημα είχα παρατηρήσει παλιότερα και σε Kubuntu και απ' ότι διάβασα κάπου είναι αναγκαίο κάνει κανείς reconfigure στον xserver (dpkg-reconfigure κλπ). Αυτό όμως δε βρήκα τρόπο να το κάνω σε SUSE. Αποκατέστησα τον παλιό xserver που είχα κρατήσει σε backup πριν την αναβάθμιση με αντιγραφή από κονσόλα αλλά και πάλι τίποτα. Καμιά ιδέα;

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

μήπως εχει σχεση με αυτό :

http://www.insomnia.gr/forum/showpost.php?p=1743729&postcount=38

 

λειπει ενα πακετο κernel της καρτας γραφικών

κατα πασα πιθανοτητα ενα dkms πακέτο για να κάνει recompile με τον καινουργιο κernel

 

μπορεις να μπεις με τον παλιό κernel ?

 

νομιζω η εντολη dpkg-reconfigure xserver-xorg δεν δουλευει σε suse αν δεν εχεις ηδη εγκατεστημενο καποιο πακετο

 

κοιτα και εδω http://en.opensuse.org/SDB:X_Server_Configuration_with_SaX2_(8.1_or_Higher)

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

DIMITRISG,

καταρχήν ευχαριστώ για την απάντηση.

Το πρόβλημα επιλύθηκε ως εξής:

Από root κονσόλα, και runlevel 3, πήγα στο folder που ήταν αποθηκευμένος ο driver της nvidia στην προ-εγκατεστημένη του μορφή και έδωσα:

sh NVIDIA-Linux-x86-100.14.19-pkg1.run -K

Δε χρειάστηκε reconfigure του xserver με την εντολή sax2 -r -m 0=nvidia, όπως αναφέρει η nvidia στο site της.

Προηγουμένως αποπειράθηκα να κάνω το παραπάνω με τον νεώτερο driver (169.07) αλλά μου έβγαλε μήνυμα ότι η έκδοση πρέπει να είναι η ίδια με αυτή που είχε νωρίτερα εγκατασταθεί.

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Οι οδηγοί της κάρτας γραφικών (και όλοι οι οδηγοί) είναι συγκεκριμένοι για τον εκάστοτε πυρήνα. Δηλαδή, αλλάζοντας τον πυρήνα, έπρεπε να "εγκαταστήσεις" εκ νέου τον οδηγό της nvidia, ουσιαστικά δηλαδή να κάνεις recompile το module για τη νέα έκδοση του πυρήνα.

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

οταν ειχα mandriva 2007 το αντιμετωπιζα αυτο μετα απο καθε update του kernel

στην 2008 το κανει αυτοματα !

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

capthhook,

Δηλαδή εγώ τι διαφορετικό έκανα;

Επιπλέον, να σημειώσω πως την εγκατάσταση των οδηγών της nvidia την έχω κάνει αναρίθμητες φορές. Κάθε φορά εγκαθιστώ την τελευταία έκδοση άσχετα με την έκδοση του πυρήνα της διανομής μου και ποτέ δεν υπήρξε πρόβλημα. Αν επομένως ισχύει ότι ένας οδηγός αντιστοιχεί σε μια και μόνο έκδοση πυρήνα, τότε θα είναι πραγματικά μεγάλη σύμπτωση που τόσες εγκαταστάσεις οδηγών έχουν γίνει απροβλημάτιστα.

 

DIMITRISG,

άσχετο με το παρόν topic, αλλά κι εγώ με Mandriva (Mandrake 9.x) ξεκίνησα στον κόσμο του linux. Στην τελευταία έκδοση (2008) αυτό που με χάλασε είναι πως στον installer του Mandriva One CD δεν περιλαμβάνεται ελληνικό localization παρόλο που στο Mandriva 2007 υπήρχε (δε μιλώ για ελληνική γλώσσα εγκατάστασης) ενώ επίσης μου έκανε εντύπωση πως ακόμα και η Γερμανία δεν περιλαμβάνεται στις βασικές χώρες (όπως περιλαμβάνονται οι νήσοι του Σολομώντος και τα νησιά Heard και McDonald!) αλλά στις "Other Countries"! Με αυτά σε συνδυασμό με κάποια προβλήματα σταθερότητας που έχω κατά καιρούς παρατηρήσει τείνω να συμπεράνω πως οι Γάλλοι έχουν τις καλύτερες προθέσεις αλλά στερούνται πρακτικού πνεύματος σε ορισμένα πράγματα.

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Πρόσεξε: όταν εγκαθιστάς τον οδηγό της nvidia με την εντολή sh NVIDIA-Linux-x86-100.14.19-pkg1.run, ουσιαστικά κάνεις compile το module nvidia.ko που είναι ο οδηγός. Το αρχείο NVIDIA-Linux-x86-100.14.19-pkg1.run που κατεβάζεις από την nvidia περιέχει τον κώδικα και επομένως μπορεί με οποιονδήποτε (θεωρητικά) πυρήνα να εγκατασταθεί, αφού γίνει το compile.

Αυτό που εννοούσα εγώ είναι πως ένα module που ήδη υπάρχει εγκατεστημένο (π.χ το προηγούμενό σου) δε μπορεί να χρησιμοποιηθεί με τον νέο kernel και γι'αυτό πρέπει να φτιάξεις ένα ίδιο (ίδια έκδοση driver nvidia) που να είναι συμβατό με τον νέο kernel.

 

 

 

Δεν ξέρω αν σε μπέρδεψα χειρότερα....

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

capthookb,

Αυτό συμπέρανα κι εγώ εμμέσως βάσει των μυνημάτων σφαλμάτων. Βασικά, αρχικά θεώρησα λογικό ότι αφού ο xserver δε σηκώνεται, ενδεχομένως να χρειάζεται απλά επανεγκατάσταση ενός driver και γι' αυτό είπα να βάλω τον τελευταίο, πράγμα που όμως δε δέχτηκε. Μέχρι τώρα πάντως δεν έχει τύχει να κάνω uninstall έναν driver και ακολούθως install ένα νεότερο. Αν έχεις υπόψη τη διαδικασία εν συντομία θα μου ήταν χρήσιμο, αλλοιώς θα το κοιτάξω σε δεύτερο χρόνο.

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

εδω φαινεται οτι με τον kernel latest παιρνω αυτοματα τον νεο kernel nvidia μετa απο update του system kernel

capture5oc5.th.png

 

δηλαδη θα ελειπε πχ ο nvidia-current-kernel-2.6.22.12-desktop-1mdv

αν το update του system kernel περασε στην εκδοση 2,6,22,12

αντε τωρα να βρεις την ονομασια του πακετου και να την κανεις apt-get ή urpmi απο command line :eek:

ενα απλο πραγμα ηταν και μου εσπαγαν τα νευρα τοσο καιρο

 

 

 

 

για το mandriva δεν το εχω δει για την υποστηριξη greek localisation αλλα αν δεν υπαρχει κακως.

παντως σε καθε update αναμενονται νεες λειτουργιες οπως πολλες απο αυτες που αναμενεται με το 2008.1 spring

http://wiki.mandriva.com/en/2008.1_General_Specifications

http://wiki.mandriva.com/en/2008.1_Detailed_Specifications

 

 

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
capthookb,

Βασικά, αρχικά θεώρησα λογικό ότι αφού ο xserver δε σηκώνεται, ενδεχομένως να χρειάζεται απλά επανεγκατάσταση ενός driver και γι' αυτό είπα να βάλω τον τελευταίο, πράγμα που όμως δε δέχτηκε. Μέχρι τώρα πάντως δεν έχει τύχει να κάνω uninstall έναν driver και ακολούθως install ένα νεότερο. Αν έχεις υπόψη τη διαδικασία εν συντομία θα μου ήταν χρήσιμο, αλλοιώς θα το κοιτάξω σε δεύτερο χρόνο.

Τον ακριβή λόγο για τον οποίο δεν τρέχει ο X-server θα μπορούσες να τη δεις από το log του, συνήθως /var/log/Xorg.log ή κάτι αντίστοιχο.

Όσον αφορά την απεγκατάσταση του nvidia δεν έχεις παρά να κάνεις:

>
NVIDIA-Linux-x86-100.14.19-pkg1.run --uninstall

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
×
×
  • Δημιουργία νέου...