Προς το περιεχόμενο

Αρχειοθετημένο

Αυτό το θέμα έχει αρχειοθετηθεί και είναι κλειστό για περαιτέρω απαντήσεις.

Dark_Sage

GCC 4.2.3 σε Kubuntu 7.10

Προτεινόμενες αναρτήσεις

Γεια χαρά παιδια...

Είναι το πρώτο μου μήνυμα που γράφω σε αυτή την ενότητα μιας κ ειμαι τελείως νέος με το Linux για αυτο θα παρακαλούσα για τη βοήθεια σας και την κατανόηση σας για να μπορέσει ακόμα ενας Windows User να μεταβεί μόνιμα σε Linux!

 

Λοιπόν η ερώτηση μου ειναι απλή...

Στην έκδοση του Kubuntu που έχω, είναι περασμενη η 4.1 GCC έκδοση... και θα ήθελα πάρα πολύ να βάλω τη νεότερη GCC 4.2.3

Το πρόβλημα ειναι πως δεν ξέρω καθόλου τι να κάνω, πως να το κάνω και απο πού να ξεκινήσω... κάτι άκουσα για build και make αλλά δεν έχω ιδέα τι σημαίνουν... για αυτό παιδια στηρίζομαι πάνω σας!

 

Thanks!

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Πές μας τον λόγο που θέλεις να βάλεις την νεώτερη έκδοση μήπως τελικά δεν χρειάζετε να κάνεις κάτι τέτοιο.

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

openmp υποστήριξη...

στο kubuntu οσο το εχω ψάξει δεν υπάρχει άλλη λύση... εχω κατεβάσει κατι πακέτα αλλα δεν λειτουργούν...

διάβασα με έκδοση 4.2.2 και πάνω όλα υποστηρίζονται μια χαρά.

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Για δες εδώ

http://www.uboontu.com/results.htm?cof=FORID:11&cx=002072379199720138921:9m-bgfzutzq&q=openmp#1171

 

αυτο το tool το έχω αγαπήσει :)

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

πάντως παιδια σας ΕΥΧΑΡΙΣΤΩ (!) όλους σας... για την πολύτιμη βοήθεια σας! Kαι για τις χρήσιμες συμβουλές σας!

Απορώ... πως θέλουν κάποιοι απο εδω μέσα να μπει το linux στη καθημερινή ζωή ενώ δε ασχολούνται καθόλου με προβλήματα που αντιμετωπίζουν νέεοι χρήστες!

φοβερή δουλειά guys! thumbs up! :mad: :-(

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Dark_Sage:

Εγώ βλέπω ότι το gutsy έχει κανονικά το πακέτο libgomp1 που δίνει υποστήριξη για OpenMP: http://packages.ubuntu.com/gutsy/libs/libgomp1

 

Το ίδιο πακέτο φέρνει κανονικά το gcc-4.2-base ως dependency, οπότε θα σου περάσει και τον gcc-4.2.1.

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
πάντως παιδια σας ΕΥΧΑΡΙΣΤΩ (!) όλους σας... για την πολύτιμη βοήθεια σας! Kαι για τις χρήσιμες συμβουλές σας!

Απορώ... πως θέλουν κάποιοι απο εδω μέσα να μπει το linux στη καθημερινή ζωή ενώ δε ασχολούνται καθόλου με προβλήματα που αντιμετωπίζουν νέεοι χρήστες!

φοβερή δουλειά guys! thumbs up! :mad: :-(

 

Συνέχισε με τέτοια ειρωνία εσύ και θα χεις τρελό support σε όποιο forum και αν πας :-)

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Dark sage:

Δεν είχα διαβάσει ολόκληρη την απάντησή σου (γι' αυτό και απάντησα στο αρχικό ερώτημα) και ειλικρινά λυπάμαι για τη στάση σου.

 

Κατ' αρχάς εδώ είμαστε ένα φόρουμ στο οποίο ο καθένας συμμετέχει στον ελεύθερό του χρόνο και για το κέφι του. Αφενός δεν είμαστε υποχρεωμένοι να λύνουμε τα προβλήματα κανενός, αφετέρου συνήθως έχουμε και άλλες δουλειές να κάνουμε. Ως εκ τούτου δε δικαιούσαι σε καμία περίπτωση να απαιτείς υποστήριξη από κάποιους που δεν έχουν καμία υποχρέωση να σου την παράσχουν.

 

Κατά δεύτερον, η απορία σου είναι πολύ εξειδικευμένη· δεν παίζει όλος ο κόσμος με OpenMP και εσύ έδωσες τελείως μα τελείως λάθος πληροφορίες («θέλω gcc-4.2.3» αντί για «θέλω openmp»). Και αν κρίνω από την όλη επιπόλαιη προσέγγιση του θέματος, δεν έκανες καν τον κόπο να ψάξεις σοβαρά.

 

Αν συνεχίσεις με τέτοια στάση, μην περιμένεις να σου λυθεί ποτέ καμία απορία, όχι μόνο εδώ, αλλά και σε οποιοδήποτε άλλο χώρο. Το Linux πάνω απ' όλα είναι συνδεδεμένο με την έννοια «κοινότητα» και δεν μπορείς να έχεις καμία απαίτηση από ανθρώπους που σε βοηθούν ενώ δεν είναι υποχρεωμένοι να το κάνουν.

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
×
×
  • Δημιουργία νέου...