Προς το περιεχόμενο

Αρχειοθετημένο

Αυτό το θέμα έχει αρχειοθετηθεί και είναι κλειστό για περαιτέρω απαντήσεις.

jim_p

Αποριες περι fstab

Προτεινόμενες αναρτήσεις

Καλημερα σε ολους.

 

Αυτο ειναι το /etc/fstab μου. (Το εβαλα σε στηλες για να ειναι ευαναγνωστο)

># /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  	<options>       		<dump>  <pass>
proc            /proc           proc    	defaults        		0       0
/dev/sda2       /               ext3    	errors=remount-ro 		0       1
/dev/sda3       none            swap    	sw              		0       0
/dev/hda        /media/cdrom0   udf,iso9660 	user,auto     			0       0
/dev/sda1	/mnt/windows	ntfs-3g		defaults,locale=el_GR.UTF-8 	0 	0
/dev/sda4	/mnt/large	ntfs-3g		defaults,locale=el_GR.UTF-8 	0 	0

 

Η τελευταια φορα που το αλλαξα ηταν οταν εβαλα το ntfs-3g. Ολα δουλευουν σχεδον τελεια. Λεω σχεδον γιατι τωρα θα το κανω τελειο :P

 

1) Γιατι λεει /dev/hda1 για το cdrom? Δεν θα επρεπε να ειναι /dev/cdrom? Δεν εχει προβλημα ακομα και ετσι. Αν κανω παντως mount /dev/cdrom /media/cdrom1, το κανει κανονικα.

2) Αν βαλω την επιπλεον επιλογη "ro" για το cdrom, θα μπορω να γραφω μετα cd?

3) Στις οδηγιες περι fstab λεει οτι η επιλογη defaults υποδηλωνει "rw, suid, dev, exec, auto, nouser, και async". Αυτο που θελω ειναι να μπορω να κανω unmount σαν απλος χρηστης. Αν βαλω defaults,user,locale... γινεται? Δεν θελω να μπλεξω με ενα σωρο επιλογες, θελω λιγες, χωρις groups και permissions, ισα ισα να γινεται η δουλεια μου απλα. Επισης, τι κανει το dev?

 

Και μια αλλη, ασχετη με fstab. Σε τι ειδους hardware απευθυνεται το παρακατω

>[email protected]:~$ apt-cache search fglrx-driver
fglrx-driver - non-free AMD/ATI r5xx, r6xx display driver

Εχω μια 3850 και δεν εχω δει καρτα της Ati να λεγεται R5??? ή R6???

 

Ευχαριστω.

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Το /dev/cdrom είναι ένα symbolic link (συντόμευση) για το /dev/hda1. Σου κάνει την ζωή ποιο εύκολη αφού είναι ποιο εύκολο να θυμάσαι το cdrom από το hdxx. Με τον τρόπο που λες δεν νομίζω να μπορέσεις να γράψεις κατευθείαν στο cd. Σαν απλός χρήστης μπορείς να χρησιμοποιείς τις εντολές pmount και pumount.

 

Το r5xx ή r6xx μπορεί να αναφέρονται στο chip της κάρτας και όχι στο ονομά της. Π.χ. Radeon 660

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

1) δες του firewalker από πανω. Μην ανησυχείς όμως αφού τις συσκευές πλέον τις κάνει αυτόματα mount το σύστημα

2) ναι, δεν έχει σχέση, απλά δηλώνεις ότι η συσκευή αυτή είναι read only κατά την ανάγνωση από εκεί

3)Φαντάζομαι στις συσκευές cd, dvd αναφέρεσαι. Εκεί μπορείς να χρησιμοποιήσεις ro, user, noauto, χωρίς defaults. Εάν βάλεις defaults στους δίσκους δεν θα μπορείς να κάνεις mount/umount σαν απλός χρήστης.

 

Αλλά όπως είπαμε το σύστημα κάνει από μόνο του mount τις συσκευές οπότε δεν σου χρειάζεται να μπορείς να κάνεις κάτι σαν απλός χρήστης.

 

To fglrx είναι ο proprietary (όχι δλδ open source) driver της ATI. Το Rxxx αναφέρεται στο chip που έχει η κάρτα σου και όχι στην ονομασία της κάρτας

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Συγγνωμη δεν το διευκρινισα :(

 

Το 3 αναφερεται στους σκληρους με ntfs.

Μαλλον για εκει θελω "rw,user,auto" δηλαδη. Αλλα μονο αυτα τα 3? Αντε 4 με το exec, αν και αχρηστο ειναι εκει.

># /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  	<options>       		<dump>  <pass>
proc            /proc           proc    	defaults        		0       0
/dev/sda2       /               ext3    	errors=remount-ro 		0       1
/dev/sda3       none            swap    	sw              		0       0
/dev/hda        /media/cdrom0   udf,iso9660 	user,auto,ro,exec		0       0
/dev/sda1	/mnt/windows	ntfs-3g		user,auto,rw,exec,locale=el_GR.UTF-8 	0 	0
/dev/sda4	/mnt/large	ntfs-3g		user,auto,rw,exec,locale=el_GR.UTF-8 	0 	0

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

το user σίγουρα ή users εάν έχεις κι άλλους. το rw νομίζω εννοείται από το ntfs-3g όπως και το auto. Κάνε μια δοκιμή...

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Χαλια τα κανα :(

 

Δεν μπορω να κανω eject, ουτε unmount το cdrom απο τις επιλογες στο δεξι κλικ. Ουτε οι σκληροι κανουν unmount. Οτι λεω ειναι για απλο χρηστη. Δεν εχω τα δικαιωματα λεει!!! Σαν sudo θα το κανει λογικα.

 

Το eject πανω στη συσκευη δεν κανει τιποτα. Αυτο το προβλημα το ειχα και πριν και ηλπιζα να το διορθωσω με το fstab.

 

Τα βαζω ολα σε default για τωρα και περιμενω καμια ιδεα.

----

Και σε defaults που τα εβαλα δεν εγινε τιποτα! Τωρα αν βαλω ενα cd στη συσκευη, πρεπει να το κανω mount πρωτα!

Παλι καλα οι σκληροι ειναι οκ.

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Μερικές παρατηρήσεις:

  • Τo auto δεν κάνει αυτό που νομίζεις ;-) Κάνει απλά mount τους δίσκους όταν λες mount -a (π.χ. στο boot), αλλά αυτό είναι το default. Κοινώς έχει νόημα να βάλεις noauto στο cdrom και να αφήσεις τα άλλα όπως ήταν
  • Με το keyword "user" μπορεί να κάνει unmount μόνο ο χρήστης που έκανε mount τη συσκευή (εν προκειμένω ο root που το έκανε στο boot αφού είναι "auto"). Άλλαξέ το σε "users" για να μπορεί να κάνει unmount οποιοσδήποτε. man 8 mount ;-)
  • Γενικά, αν πρόκειται για δίσκους εσωτερικούς, οι χρήστες δεν έχουν λόγο να τους κάνουν unmount.
  • Αν πρόκειται για δίσκους εξωτερικούς, πλέον δεν έχουν λόγο να βρίσκονται στο fstab, αφού το pmount-hal κάνει καλύτερη δουλειά ;-)
  • Για το eject, εκτός από unmount permissions, πρέπει να έχεις και write permissions στο device node για αν στείλεις την εντολή στο hardware. Κοινώς, πρέπει ή να είσαι owner του /dev/cdrom ή να ανήκεις στο owning group. Στο debian απλά βάζεις το χρήστη σου στο group "cdrom" (sudo gpasswd -a user_name cdrom).
  • Διάβασε καλά τις manpages του fstab και της mount.

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Ubuntu δεν έχεις? Ίσως κάποιος φίλος με ubuntu μπορεί να ποστάρει το fstab του και να συγκρίνεις

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

το δικο μου , δεν ειναι ubuntu αλλα μπορει να σου δωσει καμια ιδεα

># Entry for /dev/hda1 :
UUID=a70dc48e-f18e-4acc-881a-bf17ee9003d9 / ext3 relatime 1 1
# Entry for /dev/hda6 :
UUID=d1b4318e-8291-479d-bcce-1c9d290d4d99 /home ext3 relatime 1 2
/dev/cdrom /media/cdrom auto umask=0022,users,iocharset=utf8,noauto,ro,exec 0 0
/dev/cdrom2 /media/cdrom2 auto umask=0022,users,iocharset=utf8,noauto,ro,exec 0 0
/dev/fd0 /media/floppy auto umask=0022,users,iocharset=utf8,noauto,exec,flush 0 0
none /proc proc defaults 0 0
# Entry for /dev/hda5 :
UUID=4c1124b4-d5fa-4246-b557-37cfadc56caa swap swap defaults 0 0
none /proc/bus/usb usbfs auto,devmode=0666 0 0

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

@gokal: Debian testing εχω αλλα δεν ειναι εκει το θεμα. Δεν ειναι κατι που αλλαζει απο διανομη σε διανομη.

 

@apoikos: Οι ntfs δισκοι που λεω ειναι τα αλλα 2 partitions του ιδιου σκληρου. Επισης ειμαι μελος του cdrom group, αλλα με εχω βαλει με αλλο τροπο.Με usermod -a -G με εχω βαλει.

 

@dimitrisg: Ευχαριστω για την παραθεση σου, αλλα ειναι λιγο... πολυπλοκο ετσι.

 

Αυτο που θελω να κανω ειναι:

Οταν παταω το eject πανω στη συσκευη, να βγαζει οτι εχει μεσα χωρις να μπλεκω με unmounts κλπ. Γι'αυτο σκεφτηκα οτι δεν αρκει να ειμαι μελος στο cdrom group, πρεπει να μπορω να κανω και unmount αλλα αυτο να μην φαινεται καπου, απλα να γινεται!!!

Οταν κανω τερματισμο ή επανεκκινηση, μου βγαζει ενα

"Killing remaining processes failed "

το οποιο δεν το κανει αν εχω κανει πρωτα unmount τους ntfs, κατι για το οποιο θελω sudo. Σκεφτομαι λοιπον οτι θα πρεπει να μπορω να κανω unmount και σαν απλος χρηστης, οποτε κατι θα μπει στο fstab. Σωστα;

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Βρηκα το παρακατω στο wiki του Arch.

users - allow anybody to (un)mount NTFS partitions provided that the ntfs-3g binary is set SUID root (Command: chmod u+s /bin/ntfs-3g). Take note that you have to use users instead of user.

Δεν ξερω τι κανει ακριβως, αλλα ακουγεται σαν λυση στο τελευταιο προβλημα που ειπα παραπανω.

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
Δεν ξερω τι κανει ακριβως, αλλα ακουγεται σαν λυση στο τελευταιο προβλημα που ειπα παραπανω.

Μα ναι, αφού το είπε ο apoikos. Αν δε σε ενδιαφέρουν τα δικαιώματα μπορείς να βγάλεις όλα τα άλλα mount options και να ορίσεις μόνο το "users".

 

Εχω μια 3850 και δεν εχω δει καρτα της Ati να λεγεται R5??? ή R6???

Όταν λένε r5xx ή r6xx εννοούν όλες τις κάρτες των οποίων ο επεξεργαστής ανοίκει σε αυτές τις δύο οικογένειες (r500 ή r600). H 3850 φοράει επεξεργαστή r635.

http://en.wikipedia.org/wiki/Radeon_R600

 

Νομίζω ότι απαντήθηκαν όλα τα προβλήματα, εξακολουθεί να υπάρχει κάποιο;

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Λοιπον ανακεφαλαιωνω...

 

Εχω την παρακατω γραμμη στο fstab, ιδια και για τα 2 partitions.

>/dev/sda1	/mnt/windows	ntfs-3g		users,locale=el_GR.UTF-8 	0 	0

Και δεν με αφηνει να κανω mount σαν απλος χρηστης, ουτε το κανει στην εκκινηση ακομα και αν το βαλω στο auto (users,auto,locale...)!!!

Με defaults το κανει κανονικα, αλλα μου βγαζει σφαλμα στον τερματισμο η την επαννεκινηση ακομα!

 

Το eject πανω στη συσκευη εξακολουθει να μην δουλευει αν δεν κανω πρωτα unmount ή εξαγωγη!!!

 

Περι auto:

auto and noauto With the auto option, the device will be mounted automatically (at bootup, just like I told you a bit earlier, or when you issue the mount -a command). auto is the default option. If you don't want the device to be mounted automatically, use the noauto option in /etc/fstab. With noauto, the device can be mounted only explicitly.

 

Δεν λυθηκε κατι :(

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
Δώσε λίγο την έξοδο της εντολής groups.

 

>[email protected]:~$ groups
jim cdrom sudo audio video plugdev users fuse

 

Εβαλα παλι την επιλογη defaults οπως την ειχα αρχικα ΚΑΙ ΔΕΝ ΚΑΝΕΙ ΚΑΝ MOUNT στην εκκινηση. Με δεξι κλικ > mount μου λεει οτι δεν εχω τα δικαιωματα :mad:

 

 

--------

Παω λιγο εξω, να δω τι θα κανω και με το χιονι! Αλλος μπελας απο κει!

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
×
×
  • Δημιουργία νέου...