Προς το περιεχόμενο
Συνδεθείτε  
spyros__

kali nvidia drivers

Προτεινόμενες αναρτήσεις

Καλησπερα παιδια. Στον υπολογιστη εχω δυο οθονες, την μια την αναγνωρισε κανονικα, αλλα στην δευτερη η αναλυση ηταν πολυ χαμηλη. Εκανα update το συστημα, και στη συνεχεια εδωσα

apt-get install nvidia-kernel-dkms

 

Εκανα reboot και οταν επιλεγω kali linux με πεταει σε μαυρη οθονη. Μπηκα σε recovery mode για να επανελθω στην προηγουμενη κατασταση

apt-get purge nvidia-kernel-dkms

apt-get autoremove

rm /path/xorg.conf

apt-get install xserver-xorg-video-nouveau

 

Πλεον ανοιγει κανονικα αλλα δεν βλεπει καθολου την οθονη που αρχικα αναγνωριζε κανονικα.

Καμια βοηθεια?

 

Ευχαριστω!

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Ας τα παρω ενα ενα. Καταρχην, εκει που λεει για το αρχειο xorg.conf, η σωστη διαδρομη ειναι /etc/X11/xorg.conf.

 

Μετα, για να δουλεψει οτιδηποτε θελει το dkms, δηλαδη οτι τελειωνει σε -dkms, πρεπει να υπαρχουν εγκατεστημενα στο συστημα το linux-headers-blablabla (οπου blablabla η εκδοση του πυρηνα που εχεις) ΚΑΙ τα build-essential, μαζι με οτι σερνει το καθενα απο εξαρτησεις. Αν κατι λειπει, το dkms θα γκρινιαξει οτι του λειπει και δεν θα τελειωσει τη δουλεια του, οποτε παλι δεν θα εχεις βαλει καποιον driver. Σου εβγαλε κατι τετοιο?

Το linux-headers-blablabla ισως να ερχεται προεγκατεστημενο στο kali, οπως ερχεται πχ στο ubuntu. Δεν το ξερω, γιαυτο το επισημαινω.

 

Εκτος απο το nvidia-kernel-dkms, μπορεις να δοκιμασεις το πακετο nvidia-driver, που περιλαμβανει το -dkms και αρκετα ακομα που χρειαζονται για να δουλευει σωστα ο driver. Τελος, τσεκαρε οτι βλεπει την 2η οθονη απο το nvidia-settings.

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

To path το εγραψα για συντομια. Δοκιμασα και το πακετο nvidia-driver, και το αποτελεσμα ηταν παλι μαυρη οθονη. Επισης να αναφερω οτι και τις δυο φορες πριν τελειωσει η εγκατασταση μου εβγαλε το μηνυμα που εχω στη φωτογραφια.

https://postimg.org/image/l28tm3cb3/

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Το μηνυμα ειναι απλα μια προειδοποιηση που σου λεει οτι πρεπει να γινει επανεκκινηση για να ξεφορτωσει τον nouveau και να φορτωσει τον nvidia. Εκανες επανεκκινηση?

Το μονο πραγμα που εχω να προτεινω ακομα ειναι να κλεισεις το kms, μηπως o nvidia δεν το συμπαθει. Κλεινει ετσι

 

http://askubuntu.com/questions/38780/how-do-i-set-nomodeset-after-ive-already-installed-ubuntu

(εκει που λεει για το /etc/default/grub)

 

Στο debian testing που εχω, με τον nvidia και μια 9500, φροντιζω να εχω κλειστο το kms για αυτο το λογο. Το kali βασιζεται σε debian testing. Επισης, φανταζομια οτι εχεις το τελευταιο kali, 2016.x...

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Φιλε Jim δυστυχως ουτε αυτο δουλεψε, πριν την μαυρη οθονη μου εμφανιζει αυτο το μηνυμα https://postimg.org/image/89tibbz73/

Επισης nvidia settings δεν ειχα καθολου, την καρτα γραφικων μου μου την αναγνωριζε καπως αλλιως, οχι nvidia..

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Μπορεις να ποσταρεις το lspci? Μηπως ειναι λαπτοπ που εχει μια nvidia για τα ζορια + την onboard intel για τα ευκολα? Το πακετο nvidia-settings ισως να μην μπαινει με το nvidia-driver. Κανε ενα κοπο και βαλτο για να τσεκαρεις αν βλεπει την 2η οθονη απο εκει.

 

Αυτο στην εικονα λεει οτι δεν βρηκε καποιο floppy drive παρολο που φορωσε το module για αυτο, τριχες δηλαδη, και το οτι το filesystem του /dev/sda5 ειναι ok.

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Σταθερος ειναι ο υπολογιστης, αυτος που φαινεται στην υπογραφη μου. Κατεβασα το nvidia-settings, αλλα οταν το ανοιγα επαιρνα

You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run nvidia-xconfig as root), and restart the X server, οποτε εβαλα παλι το nvidia-drivers, εκανα reboot, παλι μαυρη οθονη, μπηκα σε recovery mode, εδωσα apt-get remove --purge nvidia-* και μπηκα κανονικα μετα.

 

Εδω διαβασα οτι μπορει να κανει και δεκα λεπτα με μαυρη οθονη και μετα να ειναι κομπλε http://askubuntu.com/questions/286654/nvidia-driver-installed-successfully-but-not-activated Αξιζει να το δοκιμασω?

 

00:00.0 Host bridge: Intel Corporation 4 Series Chipset DRAM Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation 4 Series Chipset PCI Express Root Port (rev 03)
00:1a.0 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #4
00:1a.1 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #5
00:1a.2 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #6
00:1a.7 USB controller: Intel Corporation 82801JI (ICH10 Family) USB2 EHCI Controller #2
00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller
00:1c.0 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 1
00:1c.4 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 5
00:1c.5 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 6
00:1d.0 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #1
00:1d.1 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #2
00:1d.2 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #3
00:1d.7 USB controller: Intel Corporation 82801JI (ICH10 Family) USB2 EHCI Controller #1
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 90)
00:1f.0 ISA bridge: Intel Corporation 82801JIR (ICH10R) LPC Interface Controller
00:1f.2 IDE interface: Intel Corporation 82801JI (ICH10 Family) 4 port SATA IDE Controller #1
00:1f.3 SMBus: Intel Corporation 82801JI (ICH10 Family) SMBus Controller
00:1f.5 IDE interface: Intel Corporation 82801JI (ICH10 Family) 2 port SATA IDE Controller #2
01:00.0 VGA compatible controller: NVIDIA Corporation GK106 [GeForce GTX 650 Ti] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GK106 HDMI Audio Controller (rev a1)
02:00.0 Ethernet controller: Qualcomm Atheros AR8121/AR8113/AR8114 Gigabit or Fast Ethernet (rev b0)
03:00.0 IDE interface: Marvell Technology Group Ltd. 88SE6121 SATA II / PATA Controller (rev b2)
05:03.0 FireWire (IEEE 1394): LSI Corporation FW322/323 [TrueFire] 1394a Controller (rev 70)
 


Επισης σαν καρτα γραφικων στις πληροφοριες μου εχει αυτη Gallium 0.4 on llvmpipe (LLVM 3.8, 128 bits)

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Δοκιμασα και με τον παρακατω τροπο

aptitude -r install linux-headers-$(uname -r)aptitude install nvidia-kernel-dkmsaptitude install nvidia-xconfig

πηρα παλι μαυρη οθονη, μπηκα σε recovery, εδωσα apt-get remove --purge nvidia-* αλλα η μαυρη οθονη συνεχισε, οποτε ξαναμπηκα σε recovery και τοτε λειτουργουσαν και οι δυο οθονες και μαλιστα με κανονικα γραμματα, οχι τεραστια. Αυτο ομως μονο σε recovery, οποτε διεγραψα το xorg.conf για να μπορω να μπω κανονικα

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Για την περιπτωση σου, δεν εχει καμια διαφορα ειτε βαλεις τα πακετα με το apt, ειτε με το aptitude. Το "linux-headers-$(uname -r)" ειναι αυτο που λεω παραπανω εγω "linux-headers-blablabla".

 

Καταρχην, μην βγαζεις τον nvidia καθε φορα, δεν εχει νοημα. Αυτον θες εγκατεστημενο, αυτον θες να δουλεψει, οχι τον nouveau. Το xorg.conf μπορεις να το σβηνεις, αν υποθεσουμε οτι αυτο περιεχει κατι λαθος, πχ να λειε nouveau αντι για nvidia. Το ιδιο το xorg.conf δεν ειναι αναγκαιο για να δουλέψει το γραφικο περιβαλλον, απλα το χρησιμοποιουμε για συγκεκριμενες καταστασεις.

Επισης, οταν ειναι φορτωμενος ο nvidia, πετιεται για μια στιγμη το λογοτυπο της nvidia οταν παει να ξεκινησει το γραφικο περιβαλλον. Σου πετιεται εσενα?

 

Οταν βγαινεις σε μαυρη οθονη, μπορεις να αλλαξεις σε tty, δηλαδη να πας με ctl+alt+f1 ως f6 σε ενα "full screen terminal"? Αν ναι, κανε login εκει με τα στοιχεια σου και δοκιμασε να κλεισεις τον dm που εχει το kali. Κλεινει ετσι

systemctl stop lightdm
υποθετοντας πως ο dm του kali ειναι ο lightdm. Θα μπορουσε να ειναι ο sddm, ο gdm3, ο slim κλπ. Μετα τρεχεις ενα startx και ελπιζεις να μην σε βγαλει σε μαυρη οθονη. Αν σε βγαλει, με ενα ctrl+c και σε γυρναει στο tty. Στα οσα βγαλει σαν πληροφοριες ο xorg, πχ φορτωθηκε ο ταδε driver, με την ταδε αναλυση κλπ, δες αν εχει καποια σειρα που να ξεκιναει με "(EE)". (ΕΕ) σημαινει errror για τον xorg και ισως να σκαλωνει καπου εκει.

 

Τελος, δοκιμασε με μια οθονη, μπας και εχεις κανενα αναπηρο desktop enviroment (= gnome ή kde) που εχει τα ψυχολογικα του οταν πρεπει να δουλεψει σε 2 οθονες.

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Οταν βγαινω σε μαυρη οθονη δυστυχως δεν μπορω να κανω τπτ, το ιδιο και με μια οθονη. Θα τα ξαναεγκαταστησω απο την αρχη, θα ξαναδοκιμασω και βλεπουμε. Θα ξαναποσταρω εδω αν χρειαστει. Ευχαριστω παρα πολυ για το κοπο και τις απαντησεις σου! 

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Δημιουργήστε έναν λογαριασμό ή συνδεθείτε για να σχολιάσετε

Πρέπει να είστε μέλος για να αφήσετε σχόλιο

Δημιουργία λογαριασμού

Εγγραφείτε με νέο λογαριασμό στην κοινότητα μας. Είναι εύκολο!

Εγγραφείτε για έναν νέο λογαριασμό

Σύνδεση

Έχετε ήδη λογαριασμό; Συνδεθείτε εδώ.

Συνδεθείτε τώρα
Συνδεθείτε  
×
×
  • Δημιουργία νέου...

Χρήσιμες πληροφορίες

Με την περιήγησή σας στο insomnia.gr, αποδέχεστε τη χρήση cookies που ενισχύουν σημαντικά την εμπειρία χρήσης.