Προς το περιεχόμενο
Συνδεθείτε  
skapodis

Πρόβλημα σε Shared Folders και εμφάνιση Windows 10 PC στο LAN

Προτεινόμενες αναρτήσεις

Δημοσ. (επεξεργασμένο)

Μετά από την εγκατάσταση των Windows 10 Pro Greek V.1903 σε PC  το οποίο βρίσκετε σε ένα απλό LAN χωρίς Domain με άλλους 5 υπολογιστές (με Windows 7), το εν λόγο PC δεν εμφανιζόταν στην περιοχή δικτύου όπως τα υπόλοιπα και δεν έβλεπε τους υπολοίπους υπολογιστές.

Επίσης το PC αυτό περιέχει Shared Folders στους οποίους πρέπει να έχουν πρόσβαση όλοι οι άλλοι υπολογιστές μέσο του LAN.

Πρόβλημα 1 – Εμφάνιση του Windows 10 Pro PC στο LAN

Πρόβλημα 2 – Εμφάνιση των υπόλοιπων υπολογιστών στο Windows 10 Pro PC

Tα παρακάτω Services πρέπει όχι μόνο να είναι Started αλλά και το Startup Type τους να είναι  Automatic το οποίο έλυσε το πρόβλημα εμφάνισης στο LAN. Για να βρείτε το όνομα του Service στα Ελληνικά Windows, ανοίξτε ένα Command Prompt παράθυρο και πληκτρολογήστε:

sc GetServiceDisplayName <Service_Name>

  • DNS Client (Service Name = Dnscache)
  • Function Discovery Resource Publication (Service Name = FDResPub)
  • SSDP Discovery (Service Name = SSDPSRV)
  • UPnP Device Host (Service Name = upnphost)
  • Function Discovery Provider Host (Service Name = fdPHost)

Στο Network & Internet Settings -> Network and Sharing Center βεβαιωνόμαστε ότι:

  • To δίκτυο μας να είναι Private (λόγω ποιο relax κανόνων στο Firewall)
  • Στα αριστερά επιλέγουμε Change advanced sharing settings
    • Στην Private λίστα
      • Turn on Network Discovery
      • Turn on file and printer sharing
      • Allow Windows to manage homegroup connections
    • Στην Guest or Public λίστα
      • Turn on Network Discovery
      • Turn on file and printer sharing
    • Στην All Networks λίστα
      • Turn on sharing so anyone with …. Folders
      • Use 128-bit encryption to help protect file sharing connections
      • Turn off password protected sharing

Και τέλος βεβαιωνόμαστε ότι όλοι οι υπολογιστές είναι στο ίδιο Workgroup (Control Panel -> System -> Change settings)

Κάνουμε reboot το PC.

Πρόβλημα 3 – Το άνοιγμα του δικτυακού Windows 10 PC (\\PC_NAME) από οποιδήποτε άλλο PC καταλήγει σε error.

Μετά την εμφάνιση του Windows 10 Pro υπολογιστή στο δίκτυο και αφού είχαν γίνει τα απαιτούμενα folders shared για δικτυακή πρόσβαση, ανοίγοντας το Windows 10 PC μέσα από το δίκτυο και από υπολογιστή με Windows 7, καταλήγει πάντα σε παράθυρο με το ακόλουθο λάθος:

You do not have permission to access \\PC_NAME contact your network administrator to request access”

Αυτό δεν είναι αποτέλεσμα κάποιας ρύθμισης αλλά από ότι φαίνεται, στις νέες αυστηρές ρυθμίσεις ασφαλείας των Windows 10 V.1903. Για να αποκτήσουμε πρόσβαση στα shared folders στο Windows 10 PC μας θα πρέπει να γράψουμε το πλήρες path του share folder:

//PC_NAME/folder_name

Πρόβλημα 4 – Το άνοιγμα και η πρόσβαση στα αρχεία των shared folders που βρίσκονται στο Windows 10 PC αργεί αρκετά (10 ~ 20 seconds).

Το θέμα ήταν στο εγκατεστημένο antivirus Symantec Endpoint Protection V.14.2.1031.0100 το οποίο είχε θέμα με τα Windows 10 Pro V.1903. Προχώρησα στην εγκατάσταση του latest patch σε όλα τα PC και το πρόβλημα σταμάτησε.

Σε περίπτωση που η καθυστέρηση υπάρχει στα Windows 10 όταν αυτά κάνουν access αρχεία στο LAN  τότε δοκιμάστε τα παρακάτω:

Ενεργοποίηση του SMB 1.0/CIFS File Sharing Protocol σε όλους τους υπολογιστές. Προσθήκη στο Registry των Windows 10 υπολογιστών των παρακάτω μεταβλητών:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

  • Δημιουργία της νέας DWORD μεταβλητής DirectoryCacheLifetime = 0
  • Δημιουργία της νέας DWORD μεταβλητής FileInfoCacheLifetime = 0
  • Δημιουργία της νέας DWORD μεταβλητής FileNotFoundCacheLifetime = 0
Επεξ/σία από skapodis

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Permissions στους κοινόχρηστους φακέλους έχεις δώσει, η το έκανες μόνο Share?
Ενεργοποίησε το SMB 1.0, κανε RR και ξαναδοκίμασε.
 

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
Δημοσ. (επεξεργασμένο)
25 λεπτά πριν, donblunts είπε

Permissions στους κοινόχρηστους φακέλους έχεις δώσει, η το έκανες μόνο Share?
Ενεργοποίησε το SMB 1.0, κανε RR και ξαναδοκίμασε.
 

Πρόσβαση στους φακέλους έχω πλέον. Απλά αργεί πολύ το άνοιγμα αρχείων μέσω LAN ανεξαρτήτος μεγέθους (10 ~ 20 seconds) (στα permission είχα βάλει εγώ Everyone R/W access από την στιγμή που βγήκε το Πρόβλημα 3). Θα δοκιμάσω το SMB 1.0 να το ανοίξω σε όλα τα PC στο LAN.

Αν δεν γίνει τίποτα τότε θα αφήσω το SMB 1.0 και θα βγάλω off το SMB Direct γιατί ακούω σε forums αρκετά issues με το SMB 3.x support από το W10 1903 Release...

Επεξ/σία από skapodis

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
3 λεπτά πριν, skapodis είπε

Πρόσβαση στους φακέλους έχω πλέον. Απλά αργεί πολύ το άνοιγμα αρχείων μέσω LAN ανεξαρτήτος μεγέθους (10 ~ 20 seconds). Θα δοκιμάσω το SMB 1.0 να το ανοίξω σε όλα τα PC στο LAN...

Αρχικά, εαν είναι εφικτό τα PC με 7άρια να γίνουν 10άρια :D

Μόνο αρχεία προσπαθείς να ανοίξεις, η συνδέεσαι σε κάποια SQL etc. ?

Δες κιόλας μήπως το θέμα είναι hardware φύσης, καλωδίωση, το switch, το patch panel, οτιδήποτε.

Τέλος, δες και το indexing στον root shared folder, απενεργοποίησε το και δοκίμασε.

16 λεπτά πριν, skapodis είπε

Αν δεν γίνει τίποτα τότε θα αφήσω το SMB 1.0 και θα βγάλω off το SMB Direct γιατί ακούω σε forums αρκετά issues με το SMB 3.x support από το W10 1903 Release...

Το Direct είναι για χρήση σε περιβάλλον με server.

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
Δημοσ. (επεξεργασμένο)
12 λεπτά πριν, donblunts είπε

Αρχικά, εαν είναι εφικτό τα PC με 7άρια να γίνουν 10άρια :D - Δυστυχώς όχι ακόμα...

Μόνο αρχεία προσπαθείς να ανοίξεις, η συνδέεσαι σε κάποια SQL etc. ? - Μόνο αρχεία

Δες κιόλας μήπως το θέμα είναι hardware φύσης, καλωδίωση, το switch, το patch panel, οτιδήποτε. - Το PC με τα Windows 10, είχε πριν Windows 7 και όλα ήταν μία χαρα στην ταχύτητα.

Τέλος, δες και το indexing στον root shared folder, απενεργοποίησε το και δοκίμασε. - Το indexing σε όλους τους δίσκους το έχω βγάλει και το Indexing Service είναι Disabled :)

Το Direct είναι για χρήση σε περιβάλλον με server.

 

Επεξ/σία από skapodis

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
Δημοσ. (επεξεργασμένο)
7 λεπτά πριν, skapodis είπε

 

Επίσημο Microsoft workaround πάντως, είναι το upgrade 7 -> 10.
Επίσης, γύρνα τις τιμές που άλλαξες στην registry στις default.

Default τιμές

"DirectoryCacheLifetime"=dword:10
"FileInfoCacheLifetime"=dword:10
"FileNotFoundCacheLifetime"=dword:5
Επεξ/σία από donblunts

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
Δημοσ. (επεξεργασμένο)
24 λεπτά πριν, donblunts είπε

Επίσημο Microsoft workaround πάντως, είναι το upgrade 7 -> 10.
Επίσης, γύρνα τις τιμές που άλλαξες στην registry στις default.

Default τιμές

"DirectoryCacheLifetime"=dword:10
"FileInfoCacheLifetime"=dword:10
"FileNotFoundCacheLifetime"=dword:5

Αυτές οι μεταβλητές κανονικά δεν υπάρχουν σε Windows 7 ούτε σε Windows 10. Το solution που δίνουν αφορά το αντίστοιχο πρόβλημα delay αλλά σε Windows 10 v.1903 όταν αυτά πάνε να κάνουν access shared resources και όχι όταν τα ίδια Windows 10 κάνουν share δικά τους resources.

Την προσθήκη στα Windows 7 την έκανα μήπως και γίνει κάτι...

Επεξ/σία από skapodis

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
48 λεπτά πριν, skapodis είπε

Αυτές οι μεταβλητές κανονικά δεν υπάρχουν σε Windows 7 ούτε σε Windows 10. Το solution που δίνουν αφορά το αντίστοιχο πρόβλημα delay αλλά σε Windows 10 v.1903 όταν αυτά πάνε να κάνουν access shared resources και όχι όταν τα ίδια Windows 10 κάνουν share δικά τους resources.

Την προσθήκη στα Windows 7 την έκανα μήπως και γίνει κάτι...

Και; Είδες διαφορά;
 

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
Δημοσ. (επεξεργασμένο)

Θα κάνω τις αλλαγές στο SMB μόλις πάω σπίτι...

Επεξ/σία από skapodis

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
1 λεπτό πριν, skapodis είπε

Θα κάνω τις αλλαγές μόλις πάω σπίτι...

Δοκίμασε να απενεργοποιήσεις το IPv6 απ'τις NIC

 

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
Στις 9/10/2019 στις 4:43 ΜΜ, skapodis είπε

Σε όλους είναι off όπως επίσης και το QoS

Έχουμε κανα νέο;

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
Δημοσ. (επεξεργασμένο)

Λοιπόν. Το θέμα ήταν στο εγκατεστημένο antivirus Symantec Endpoint Protection V.14.2.1031.0100 το οποίο είχε θέμα με τα Windows 10 Pro V.1903. Προχώρησα στην εγκατάσταση του latest patch σε όλα τα PC και το πρόβλημα σταμάτησε.

Επεξ/σία από skapodis

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Δημιουργήστε έναν λογαριασμό ή συνδεθείτε για να σχολιάσετε

Πρέπει να είστε μέλος για να αφήσετε σχόλιο

Δημιουργία λογαριασμού

Εγγραφείτε με νέο λογαριασμό στην κοινότητα μας. Είναι εύκολο!

Εγγραφείτε για έναν νέο λογαριασμό

Σύνδεση

Έχετε ήδη λογαριασμό; Συνδεθείτε εδώ.

Συνδεθείτε τώρα
Συνδεθείτε  
×
×
  • Δημιουργία νέου...

Χρήσιμες πληροφορίες

Με την περιήγησή σας στο insomnia.gr, αποδέχεστε τη χρήση cookies που ενισχύουν σημαντικά την εμπειρία χρήσης.