Προς το περιεχόμενο
Green Dragon

Υπάρχει ασυμβατότητα Linux και Ryzen - Vega;;;

Προτεινόμενες αναρτήσεις

Καλημέρα παιδιά.

Έχω ένα laptop Lenovo 330S με ryzen 5 2500U και ενσωματωμένα γραφικά Vega 8. Και 2 δίσκους, έναν Μ2 NVME πού έχει τα Win 10 και έναν SSD που προς το παρόν είναι άδειος.

Έχω δοκιμάσει αρκετές διανομές (ubuntu 18.10, Mint 19.1, Manzaro κ.λπ.)…, έχω δοκιμάσει όλους τους τρόπους και τα προγράμματα να φτιάξω bootable usb flash, έχω χρησιμοποιήσει και τους δύο δίσκους για εγκατάσταση, αλλά τίποτα.

Κανένα δεν κατάφερα να εγκαταστήσω. Μόλις το laptop κάνει boot από το usb και εμφανίζεται το μενού:....try ή install και δίνω επιλογή...τίποτα...μαύρη οθόνη και νέκρα...

Δεν μπορώ να φανταστώ τι φταίει και δεν ξέρω πως να προχωρήσω, εκτός από virtual machine.

Καμμιά ιδέα;;;;

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
Δημοσ. (επεξεργασμένο)

Έχουν θέμα τα Lenovo με τον συγκεκριμένο Ryzen. Πρέπει να περάσεις το συγκεκριμένο boot parameter στον grub:

pci=noacpi

Θα μπουτάρεις κανονικά το φλασάκι της διανομής και μόλις εμφανίσει τις επιλογές για install ή try, επιλέγεις το install (δεν πατάς enter) και θα πατήσεις το πλήκτρο 'e' 

Μετά θα βρεις τη γραμμή /vmlinuz που είναι ο kernel και στο τέλος της γραμμής θα προσθέσεις το pci=noacpi που έγραψα πάνω. Πρόσεχε να έχει κενό πριν τη προηγούμενο εντολή.

Και για να προχωρήσει το install πατάς ctrl+x

Επεξ/σία από thomasG4
  • Thanks 2

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
Δημοσ. (επεξεργασμένο)
4 ώρες πριν, thomasG4 είπε

Έχουν θέμα τα Lenovo με τον συγκεκριμένο Ryzen. Πρέπει να περάσεις το συγκεκριμένο boot parameter στον grub:

pci=noacpi

Θα μπουτάρεις κανονικά το φλασάκι της διανομής και μόλις εμφανίσει τις επιλογές για install ή try, επιλέγεις το install (δεν πατάς enter) και θα πατήσεις το πλήκτρο 'e' 

Μετά θα βρεις τη γραμμή /vmlinuz που είναι ο kernel και στο τέλος της γραμμής θα προσθέσεις το pci=noacpi που έγραψα πάνω. Πρόσεχε να έχει κενό πριν τη προηγούμενο εντολή.

Και για να προχωρήσει το install πατάς ctrl+x

Δεν γίνεται δυστυχώς!  Έκανα αυτό που έγραψες, φόρτωσε το Mint και έκανα εγκατάσταση στο δεύτερο δίσκο. Μόλις τελείωσε, μου ζήτησε να κάνω επανεκκίνηση. Στην επανεκκίνηση δεν φόρτωσε και μου έβγαλε μαύρη οθόνη.

Μπήκα στο bios setup, να δω πως έχει φτιάξει το boot priority και έχει:

https://postimg.cc/tYckK8CL

Βάζω να κάνει boot από τον δίσκο που έχει εγκατεστημένο το Mint.....από τον Kingston και μου βγάζει δεύτερο μήνυμα λάθους:

https://postimg.cc/mPdXghw6

Και τέλος ορίζω τον Windows boot manager και μου βγάζει άλλο μήνυμα λάθους:

https://postimg.cc/WhqbnJD0

Λέω να τα παρατήσω.

 

Επεξ/σία από Green Dragon

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
1 λεπτό πριν, Green Dragon είπε

Δεν γίνεται δυστυχώς!  Έκανα αυτό που έγραψες, φόρτωσε το Mint και έκανα εγκατάσταση στο δεύτερο δίσκο. Μόλις τελείωσε, μου ζήτησε να κάνω επανεκκίνηση. Στην επανεκκίνηση δεν φόρτωσε και μου έβγαλε μαύρη οθόνη.

Μπήκα στο bios setup, να δω πως έχει φτιάξει το boot priority και έχει:

https://postimg.cc/WhqbnJD0

Αυτή η ρύθμιση που σου είπα να κάνεις είναι μόνο για να μπεις στη live διανομή και να κάνεις εγκατάσταση. Θα πρέπει κάπως οι ρυθμίσεις να μπουν μόνιμα και στην εγκατάσταση. Όταν θα κάνεις boot και κολλήσει στη μαύρη οθόνη, πατάς alt+ctrl+F3, δίνεις τα στοιχεία που έδωσες στην εγκατάσταση για το χρήστη + κωδικό. Μετά ακολουθείς τα παρακάτω βήματα για να κάνεις μόνιμη τη ρύθμιση και να μπουταρει σωστά ο kernel(ακολουθείς αυτά που λέει To make this change permanent):

https://askubuntu.com/questions/19486/how-do-i-add-a-kernel-boot-parameter

Αντι για foo=bar που λεει αυτός εσύ βάζεις πάλι το pci=noacpi που έβαλες και πριν.

 

 

  • Thanks 1

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
2 ώρες πριν, Green Dragon είπε

OK.... Θα το δοκιμάσω και θα ενημερώσω 😏

Το φορητο μια καρτα εχει ε?Ανταλλασουμε ? :)

  • Like 1

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Τι εννοείς βρε;;;

Φαγώθηκες πια! Εξ' αιτίας σου δεν μπορώ να περάσω ένα λινουξάκι🤣

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Κάνω αυτά που μου είπες thomas, αλλά τίποτα δεν μου βγαίνει. Συνέχεια παίρνω μηνύματα λάθους. Δεν μπορώ να καταλάβω τι δεν ταιριάζει, αλλά δεν θα συνεχίσω, γιατί φοβάμαι ότι θα κάνω άνω-κάτω το σύστημά μου.

Θα περιμένω ίσως κάποια καινούργια διανομή με νεότερο Kernel, που να ταιριάζει περισσότερο. Και drivers από Lenovo και amd. Μέχρι τότε virtualbox.

Σε ευχαριστώ για τον χρόνο και το ενδιαφέρον σου.

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
Δημοσ. (επεξεργασμένο)
28 λεπτά πριν, Green Dragon είπε

Κάνω αυτά που μου είπες thomas, αλλά τίποτα δεν μου βγαίνει. Συνέχεια παίρνω μηνύματα λάθους. Δεν μπορώ να καταλάβω τι δεν ταιριάζει, αλλά δεν θα συνεχίσω, γιατί φοβάμαι ότι θα κάνω άνω-κάτω το σύστημά μου.

Θα περιμένω ίσως κάποια καινούργια διανομή με νεότερο Kernel, που να ταιριάζει περισσότερο. Και drivers από Lenovo και amd. Μέχρι τότε virtualbox.

Σε ευχαριστώ για τον χρόνο και το ενδιαφέρον σου.

Για δες εδω.Και εδω (κατω κατω).Eπισης δοκιμασε να παιξεις με fedora rawhide που ερχεται απο την μανα του με 4.20 κερνελ να δεις τι γινεται εκει περα.Αν ειναι θεμα δηλ κερνελ εντελει , απλα εγκαθιστας καποιο ubuntu-οειδες , αρκει να μπουταρει ακομα και σε κονσολα και περνας τον τελευταιο κερνελ (ναι γινεται).
Επισης καλο ειναι να περνιεται και το amd-microcode στις δοκιμες/εγκαταστασεις.

EDIT : Επισης παρατηρησαν και ενα θεμα με το turbo frequency .Εχε και το παρακατω στα υποψη.
 

Spoiler

Found the issue. If I enable the HDD with Windows that enables the EFI bootloader, then the turbo mode doesn't work.

If the Legacy bootloader is enabled and the EFI bootloader isn't, then turbo frequencies work normally.

Just need a way now handle turbo frequencies with EFI.

 

Επεξ/σία από mphxths
  • Like 1
  • Thanks 1

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
Στις 13/12/2018 στις 1:33 ΜΜ, thomasG4 είπε

Έχουν θέμα τα Lenovo με τον συγκεκριμένο Ryzen. Πρέπει να περάσεις το συγκεκριμένο boot parameter στον grub:

pci=noacpi

Θα μπουτάρεις κανονικά το φλασάκι της διανομής και μόλις εμφανίσει τις επιλογές για install ή try, επιλέγεις το install (δεν πατάς enter) και θα πατήσεις το πλήκτρο 'e' 

Μετά θα βρεις τη γραμμή /vmlinuz που είναι ο kernel και στο τέλος της γραμμής θα προσθέσεις το pci=noacpi που έγραψα πάνω. Πρόσεχε να έχει κενό πριν τη προηγούμενο εντολή.

Και για να προχωρήσει το install πατάς ctrl+x

Λοιπόν για να σας ενημερώσω, αφού εχθές κατάφερα να ασχοληθώ πάλι:

Εγκατέστησα κανονικά στον δεύτερο δίσκο το Mint 19.1 και μόλις τελείωσε η εγκατάσταση έκανα επανεκκίνηση. Φυσικά δεν έκανε boot, ως συνήθως.

Στη δεύτερη προσπάθεια να κάνω boot, πάτησα το Ε και μετά βρήκα τη γραμμή:    Linux/vmlinuz που είναι ο kernel και στο τέλος της γραμμής, άφησα κενό και έγραψα    "noapic" και F10.

Αμέσως μπήκε στην πρώτη οθόνη του Mint που ζητάει κωδικούς κ.λ.π. Όλα καλά λοιπόν μέχρι εδώ, με μερικά προβλήματα. 1) Η οθόνη σκοτείνιασε πολύ, στα όρια να μην μπορώ να δουλέψω και δεν ήξερα πως να αυξήσω τη φωτεινότητα της. 2) Ακολούθησα τον οδηγό παραπάνω, αλλά δεν κατάφερα να κάνω τη αλλαγή μόνιμη.

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
9 λεπτά πριν, Green Dragon είπε

Λοιπόν για να σας ενημερώσω, αφού εχθές κατάφερα να ασχοληθώ πάλι:

Εγκατέστησα κανονικά στον δεύτερο δίσκο το Mint 19.1 και μόλις τελείωσε η εγκατάσταση έκανα επανεκκίνηση. Φυσικά δεν έκανε boot, ως συνήθως.

Στη δεύτερη προσπάθεια να κάνω boot, πάτησα το Ε και μετά βρήκα τη γραμμή:    Linux/vmlinuz που είναι ο kernel και στο τέλος της γραμμής, άφησα κενό και έγραψα    "noapic" και F10.

Αμέσως μπήκε στην πρώτη οθόνη του Mint που ζητάει κωδικούς κ.λ.π. Όλα καλά λοιπόν μέχρι εδώ, με μερικά προβλήματα. 1) Η οθόνη σκοτείνιασε πολύ, στα όρια να μην μπορώ να δουλέψω και δεν ήξερα πως να αυξήσω τη φωτεινότητα της. 2) Ακολούθησα τον οδηγό παραπάνω, αλλά δεν κατάφερα να κάνω τη αλλαγή μόνιμη.

Για να γίνει μόνιμη η αλλαγή όπως είπα και πιο πάνω πρέπει να ακολουθήσεις αυτό τον οδηγό:

https://askubuntu.com/questions/19486/how-do-i-add-a-kernel-boot-parameter

Πιο αναλυτικά:

Απο τη στιγμή που μπαίνεις προσωρινά στο desktop, δώσε στο terminal αυτή τη εντολή:

sudo nano /etc/default/grub

Δινεις το κωδικό σου. Μετά πρόσθεσε αυτά τα δυο εκεί που λεει GRUB_CMDLINE_LINUX_DEFAULT=

Αυτές οι καινούριες γραμμές λογικά θα σου φτιάξουν και τη φωτεινότητα

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"

Μετά πατάς ctrl+o και μετά ctrl+x για να βγεις απο τον editor.

Δίνεις αυτή τη εντολή για εφαρμοστούν οι αλλαγές που έκανες στον kernel:

sudo update-grub

Άμα πάλι δεν μπαίνει τότε δοκίμασε να εγκαταστήσεις το Manjaro που έχει πιο καινούριο kernel και ξανακάνε τα ίδια.

  • Thanks 1

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"

Αυτά υποθέτω ότι πάνε σε μία σειρά... Οκ; 

Μετά κλείνω τον editor και σε τερματικό δίνω το sudo update-grub..... 

Έτσι νομίζω γίνονται μόνιμες οι αλλαγές... Σωστά; 

 

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
Δημοσ. (επεξεργασμένο)
2 ώρες πριν, Green Dragon είπε
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"

Αυτά υποθέτω ότι πάνε σε μία σειρά... Οκ; 

Μετά κλείνω τον editor και σε τερματικό δίνω το sudo update-grub..... 

Έτσι νομίζω γίνονται μόνιμες οι αλλαγές... Σωστά; 

Η σειρά μέσα στο αρχείο κανονικά θα είναι:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Εσύ θα προσθέσεις τα άλλα δυο. Πρόσεχε όταν προσθέσεις τα καινούρια να υπάρχει η απόστροφος στο τέλος.

Ναι όπως είπα τα βήματα και έτσι θα γίνουν μόνιμες οι αλλαγές, απλά θα πρέπει να δούμε άμα θα δουλέψει με το acpi_osi=Linux

Έβαλα αυτό γιατί με τη προηγούμενη εντολή ενώ έμπαινε δεν θα έχεις έλεγχο της φωτεινότητας. Με αυτή τη εντολή μπορεί να μπει χωρίς μαύρη οθόνη αλλά και να λειτουργεί η φωτεινότητα.

Επεξ/σία από thomasG4

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
Δημοσ. (επεξεργασμένο)

Αντί για το manjaro σκέφτηκα να δοκιμάσω το ubuntu 18.10, που είναι πιό διαδεδομένο και με νεότερο kernel και αυτό.

Εγκαταστάθηκε πολύ εύκολα στον δεύτερο δίσκο και μετά την επανεκκίνηση έπαιξε με τη μία....out of the box....που λέμε. Δεν το περίμενα! Σε ευχαριστώ Thomas και όλα τα άλλα παιδιά για τη βοήθειά σας!

Επεξ/σία από Green Dragon

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
7 ώρες πριν, Green Dragon είπε

Αντί για το manjaro σκέφτηκα να δοκιμάσω το ubuntu 18.10, που είναι πιό διαδεδομένο και με νεότερο kernel και αυτό.

Εγκαταστάθηκε πολύ εύκολα στον δεύτερο δίσκο και μετά την επανεκκίνηση έπαιξε με τη μία....out of the box....που λέμε. Δεν το περίμενα! Σε ευχαριστώ Thomas και όλα τα άλλα παιδιά για τη βοήθειά σας!

Το Manjaro έχει πιο καινούριο kernel btw

Αλλά αφού σου δούλεψε με το Ubuntu 18.10 , τότε μια χαρά.

  • Like 1

Κοινοποιήστε αυτήν την ανάρτηση


Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Δημιουργήστε έναν λογαριασμό ή συνδεθείτε για να σχολιάσετε

Πρέπει να είστε μέλος για να αφήσετε σχόλιο

Δημιουργία λογαριασμού

Εγγραφείτε με νέο λογαριασμό στην κοινότητα μας. Είναι εύκολο!

Εγγραφείτε για έναν νέο λογαριασμό

Σύνδεση

Έχετε ήδη λογαριασμό; Συνδεθείτε εδώ.

Συνδεθείτε τώρα
×
×
  • Δημιουργία νέου...

Χρήσιμες πληροφορίες

Με την περιήγησή σας στο insomnia.gr, αποδέχεστε τη χρήση cookies που ενισχύουν σημαντικά την εμπειρία χρήσης.