Προς το περιεχόμενο

[INFO] ARCH Linux: Απόψεις, Ερωτήσεις, Σχόλια


jemadux

Προτεινόμενες αναρτήσεις

Αν δεν κανω λάθος, το okular ειναι ο default pdf-viewer στο KDE. Στις ρυθμισεις του Kile μπορείς να βάλεις όποιον pdf-viewer θέλεις.

 

Αν το προβλημα ηταν αυτο πάντως, τοτε δεν είχε σχέση με το να μη "σου φτιανει τα pdf".

Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
  • Απαντήσεις 4,1k
  • Δημιουργία
  • Τελευταία απάντηση

Συχνή συμμετοχή στο θέμα

Συχνή συμμετοχή στο θέμα

Δημοφιλή Μηνύματα

http://deltahacker.gr/2012/12/01/deltacast-s01e01/

$ systemd-analyze Startup finished in 1.597s (kernel) + 1.020s (userspace) = 2.618s

Δημοσιευμένες Εικόνες

ναι δεν φαινεται να έχει πρόβλημα το πρόγραμμα αλλα το πακέτο του arch. δεν θα πρεπε εστω να το δειχνει ως optional dependency? στο error εδειχνε απλα error 1 ... για κάποιον που βλέπει το πρόγραμμα για πρώτη φορά και δεν χρησιμοποιεί kde είναι κάπως μπέρδεμα.

Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Αν νομίζεις οτι πρέπει να το δείχνει ως dependency μπορείς να ανοίξεις ένα ticket στον bug tracker. Από εκεί και πέρα, μια καλή αρχή όταν μαθαίνεις LaTeX, προγραμματισμό κτλ είναι να μάθεις πρώτα τα εργαλεία της command line και μετά να πας στο IDE. Πχ

 

xelatex my_file.tex

xelatex my_file.tex

evince my_file.pdf

Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

P.S. Τα χρησιμοποιώ όλα, ανάλογα με τα κέφια... PacmanXG, Software Updates (Gnome), pacaur, yaourt.... 

Χρειάζεται λίγη προσοχή στα εργαλεία που βασίζονται στο packagekit. Στο arch το packagekit είναι μία major έκδοση πίσω (νομίζω λόγω bindings) και λόγω σχεδίασης, αυτά τα εργαλεία δεν δείχνουν το output του pacman. Τα pacmanXG, octopi και -αν ενδιαφέρεσαι για ενημέρωση και updates από tray applet- το kalu δεν έχουν τέτοια προβλήματα.

  • Like 2
Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Χρειάζεται λίγη προσοχή στα εργαλεία που βασίζονται στο packagekit. Στο arch το packagekit είναι μία major έκδοση πίσω (νομίζω λόγω bindings) και λόγω σχεδίασης, αυτά τα εργαλεία δεν δείχνουν το output του pacman. Τα pacmanXG, octopi και -αν ενδιαφέρεσαι για ενημέρωση και updates από tray applet- το kalu δεν έχουν τέτοια προβλήματα.

Thanx ! Δεν τα είχα δώσει ιδιαίτερα σημασία διότι νόμιζα ότι το packagekit είχε καλό δέσιμο με το arch. Θα τα ξεριζωσω και θα βάλω τo kalu που ανέφερες. Με ενδιαφέρει απλά μια υπενθύμιση στο Gnome shell για το αν υπάρχουν αναβαθμίσεις από AOR και AUR

Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Μια περίεργη απορία - πάλι δεν νομίζω arch specific.

Γενικά χρησιμοποιώ guake για terminal emulator. Σήμερα παρατήρησα κάτι περίεργο. Ενώ όταν ανοίγω ένα tab στο guake και δίνω whoami επιστρέφει κανονικά το όνομα χρήστη μου, εντολές όπως users, w και finger δεν επιστρέφουν κανένα αποτέλεσμα. Δηλαδή δείχνουν ότι δεν είμαι συνδεδεμένος!

Δοκιμάζοντας τις ίδιες εντολές σε xterm και gnome-terminal παίρνω το αναμενόμενο αποτέλεσμα και με δείχνουν logged in και μάλιστα αν όσο έχω ανοιχτό κάποιον απ' αυτούς τους terminal emulators γυρίσω στον guake τότε και εκεί πέρα φαίνομαι συνδεδεμένος. Φυσικά αυτό διαρκεί μέχρι να κλείσω όλους τους υπόλοιπους emulators και να μείνω μόνο με guake οπότε και πάλι δεν φαίνεται κανείς χρήστης να είναι συνδεδεμένος στο σύστημα.

Καμιά ιδέα τι μπορεί να παίζει;

post-236139-0-98742300-1393705363_thumb.png


 

Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Ασχετο λιγο με την απορια σου Ηλια,αλλα ειδα οτι σου αρεσει το guake(οπως κι εμενα!),απλα επειδη φαινεται να εχεις xfce o built-in τερματικος του,εχει δυνατοτητα για drop-down,οποτε δεν ειναι αναγκη να εχεις guake και να σερνεις και τα dependencies του.Ειναι λιγοτερο παραμετροποιησιμο αλλα μπορεις να το δοκιμασεις.

 

https://www.dropbox.com/s/j75isdl56la7fo0/Screenshot%20-%2003022014%20-%2003%3A32%3A12%20AM.png

Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

@martinoff
Ναι, όντως το έβαλα στο zshrc και δούλεψε! Είναι εύκολο να εξηγήσεις και το γιατί; Το προηγούμενο default TERM ήταν το xterm αλλά και το gnome-terminal δούλευε κανονικά για παράδειγμα. Τι έτρεχε με το guake;

@stratos_21
LXDE έχω, όχι XFCE.


Edit:
Εμ... τελικά άκυρο τα πράγματα δεν δουλεύουν και τόσο καλά.

Όταν ανοίγω οποιονδήποτε terminal emulator αρχικά παίρνω:

/home/ilias/.dotfiles/zsh/zshrc:43: can't find terminal definition for guake

Μετά αν δώσω για παράδειγμα:

[email protected] ~  ➜ man ls
WARNING: terminal is not fully functional
-  (press RETURN)

Αν δώσω vim:

E558: Terminal entry not found in terminfo
'guake' not known. Available builtin terminals are:
    builtin_gui
    builtin_amiga
    builtin_beos-ansi
    builtin_ansi
    builtin_pcansi
    builtin_win32
    builtin_vt320
    builtin_vt52
    builtin_xterm
    builtin_iris-ansi
    builtin_debug
    builtin_dumb
defaulting to 'ansi'

Επίσης αν ανοίξω πολλούς te:

[email protected] ~  ➜ users
ilias ilias ilias ilias
[email protected] ~  ➜

:-(

Μαντεύω ότι οφείλεται στο παρακάτω:

[email protected] ~  ➜ echo $SHELL
/bin/zsh
[email protected] ~  ➜ export TERM=guake
zsh: can't find terminal definition for guake
[email protected] ~  ➜ bash
[[email protected] ~]$ export TERM=guake
[[email protected] ~]$

Δηλαδή στον bash φαίνεται να δουλεύει κανονικά, ενώ στον zsh όχι.

Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Thanx ! Δεν τα είχα δώσει ιδιαίτερα σημασία διότι νόμιζα ότι το packagekit είχε καλό δέσιμο με το arch. Θα τα ξεριζωσω και θα βάλω τo kalu που ανέφερες. Με ενδιαφέρει απλά μια υπενθύμιση στο Gnome shell για το αν υπάρχουν αναβαθμίσεις από AOR και AUR

Δεν λέω ότι δεν δουλεύει, αν δεν δούλευε δεν θα ήταν στο community repo - όλη η δουλειά και η συντήρησή του γίνεται από την κοινότητα του arch.

Αν θες να το χρησιμοποιείς για ειδοποίηση μόνο, τότε δύσκολα θα έχεις πρόβλημα.

Η έκδοση που χρησιμοποιεί το arch είναι η 0.7.6, η οποία βγήκε από το upstream  στις 21/08/2012, την στιγμή που η τελευταία διαθέσιμη είναι η 0.8.16 (20/01/2014).

Τα... στοιχεία είναι από τον ftp server του freedesktop: http://www.packagekit.org/releases/

Ο λόγος που το gnome-packagekit είναι στην τελευταία έκδοση, ενώ το backend είναι παλιότερο, είναι ότι το API είναι παγωμένο: http://www.packagekit.org/pk-download.html

Το πακέτο είναι στην 11η revision (αναθεώρηση αν προτιμάς στα ελληνικά) που σημαίνει ότι έχει γίνει αρκετή δουλειά και έχει 3 patches, από τα οποία το ένα είναι αρκετά μεγάλο -και έχει να κάνει με το backend: 

https://projects.archlinux.org/svntogit/community.git/tree/trunk?h=packages/packagekit

Το πρόβλημα είναι ότι ο pacman είναι εντελώς προσανατολισμένος στο cli και το output του δεν είναι διακοσμητικό. Οι gui package managers που προσπάθησαν να τον αντικαταστήσουν πλήρως (με πιο γνωστή περίπτωση τον shaman στο παρελθόν) είχαν τραγικές αποτυχίες. Οι πιο σύγχρονοι (PacmanXG, octopi) στην φάση της εγκατάστασης, απλά τρέχουν τον pacman όπως ακριβώς θα έτρεχε και στο cli.

Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

παραγγειλα ενα λαπιτοπι και οταν ερθει θελω να μεταφερω την τωρινη μου εγκατασταση σε αυτο. (απο HDD σε SSD)

 

πως να το κανω αυτο?

 

clone?

clean install?

system-tar-and-restore? :P

αλλος τροπος?

 

εχω διαβασει αυτα τα βικι (1, 2), αλλα θα ηθελα και μια δευτερη γνωμη. :rolleyes:

Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Εγώ πάντως πρόσφατα χρησιμοποίησα το system tar & restore απο hdd σε ssd και όλα δούλεψαν τέλεια.

 

Κάνεις ένα backup στο παλιό, παίρνεις το archive, μπαίνεις με live cd στο καινούριο, ξεκινάς το system tar & restore, δινεις το archive απο ένα USB stick και είσαι έτοιμος.

 

Μπορεί μόνο να πρέπει να ρυθμίσεις drivers για την κάρτα γραφικών αν δεν είναι ίδιας εταιρίας.

  • Like 1
Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

SOS, δε λειτουργεί τίποτα...

$ sudo pacman -Syu

sudo: unable to write to /var/db/sudo/hk/0 : Read-only file system

sudo: unable to execute /usr/bin/pacman : input/output error

 

$ ls

/usr/bin/ls : Input/output error

 

$ cat comm

cat: comm: No such file or directory

 

Με cd δε γίνεται τίποτα, λέει ότι δεν υπάρχει το αρχείο. Οι συντομεύσεις του πληκτρολογίου δε δουλεύουν εκτός από αυτήν που ανοίγει το terminal. Η συντόμευση που ανοίγει το launcher επίσς δε δουλεύει..

 

Τι κάνω;

Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Δημιουργήστε ένα λογαριασμό ή συνδεθείτε για να σχολιάσετε

Πρέπει να είστε μέλος για να αφήσετε σχόλιο

Δημιουργία λογαριασμού

Εγγραφείτε με νέο λογαριασμό στην κοινότητα μας. Είναι πανεύκολο!

Εγγραφείτε για έναν νέο λογαριασμό

Σύνδεση

Έχετε ήδη λογαριασμό; Συνδεθείτε εδώ.

Συνδεθείτε τώρα

  • Δημιουργία νέου...

Με την περιήγησή σας στο insomnia.gr, αποδέχεστε τη χρήση cookies που ενισχύουν σημαντικά την εμπειρία χρήσης.