Προς το περιεχόμενο
  • Εγγραφή

Home Assistant Hassio RPi


Spect~

Προτεινόμενες αναρτήσεις

Δημοσ. (επεξεργασμένο)
10 ώρες πριν, fingolfingr είπε

Πριν από λίγες μερες ηρθε μια πλακέτα ESP32 που αγορασα ώστε να συνδεσω το home assistant με μερικά θερμομετρακια xiaomi ακολουθωντας καποιους οδηγους στο youtube.

 

Συνεδεσα την πλακέτα με το ha και ξεκινησα το flashαρισμα αλλα δεν συνδεεται με τίποτα στο wifi. Του εβαλα και στατική αλλα και παλι.... τίποτα. Ο κωδικός του wifi περιέχει γραμματα, αριθμους και συμβολα. Δεν μπορώ να τον αλλαξω γιατί είναι περασμενος παντου. Υπάρχει περιπτωση να είναι αυτό το πρόβλημα;

 

Αν επιλέξω το generic μοντελο για esp32 βγάζει κατι αλλο

image.png.b0fa24402862de1f8d5354b63776adc2.png

Αν επιλέξω το generic μοντέλο για esp32 βγάζει κατι αλλο

image.png.c9c3e365e134a321a676cb6a3a5fbea0.png

 

Καμια ιδέα;

 

Θεωρώντας ότι αυτή είναι η πρώτη φορά που πας να κάνεις flash την συσκευή, πρέπει να την συνδέσεις με USB για να την flasharεις. To πρώτο error που βλέπω θα συνέβαινε πχ εάν το είχες αφήσει να κάνεις upload over the air, αλλά εφόσον δεν υπάρχει συσκευή στο δίκτυο σου με το όνομα δεν ξέρει που να κάνει το upload. 

Π.χ. image.png.a52496169669f4401612ab7e053d5b28.pngτο ίδιο error ακριβώς αν κάνω ένα νέο node και το αφήσω να κάνει upload σε ένα χχχ.local που προφανώς δεν υπάρχει.

EDIT: Τώρα είδα όμως ότι στην δεύτερη προσπάθει όντως λέει ότι προσπαθεί over serial άρα μάλλον το έχεις όντως με καλώδιο. Εάν όντως μπορεί να φταίει ο κωδικός δοκίμασε να τον αλλάξεις σε κάτι τελείωε απλό στο yaml απλά για να δεις εάν το flasharisma τότε είναι επιτυχές ή πάλι τα ίδια. Επίσης βάζεις τον κωδικό μέσα σε ' ' ? 

Δηλαδή password: 'kati_edw'

Επεξ/σία από than2031995
Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
  • Απαντήσεις 1,3k
  • Δημιουργία
  • Τελευταία απάντηση

Συχνή συμμετοχή στο θέμα

Συχνή συμμετοχή στο θέμα

Δημοφιλή Μηνύματα

Hello. Υλοποίησα ένα μικρό σύστημα συναγερμού με το homeassistant και esphome (με την καθοδήγηση του @than2031995) Υλικό: Παγίδες: https://www.skroutz.gr/s/23975046/Anga-MC-38W-Μαγνητικ

Η δικιά μου τον τελευταίο καιρό. Η κύρια τουλάχιστον είναι αυτή. Κάποια στιγμή θα την αλλάξω πιστεύω βέβαια ή θα κάνω ένα δεύτερο dashboard για να είναι πιο mobile friendly.  Για πόρτες τα έχω

Χαιρετώ την κοινότητα του Home assistant.  Ανέβασα οδηγίες για integration του Speedport Plus modem που δίνει ο ΟΤΕ με Home assistant και InfluxDB/Grafana σε αυτό το github repo.  Home assis

Δημοσιευμένες Εικόνες

Δημοσ. (επεξεργασμένο)
11 ώρες πριν, than2031995 είπε

Θεωρώντας ότι αυτή είναι η πρώτη φορά που πας να κάνεις flash την συσκευή, πρέπει να την συνδέσεις με USB για να την flasharεις. To πρώτο error που βλέπω θα συνέβαινε πχ εάν το είχες αφήσει να κάνεις upload over the air, αλλά εφόσον δεν υπάρχει συσκευή στο δίκτυο σου με το όνομα δεν ξέρει που να κάνει το upload. 

Π.χ. image.png.a52496169669f4401612ab7e053d5b28.pngτο ίδιο error ακριβώς αν κάνω ένα νέο node και το αφήσω να κάνει upload σε ένα χχχ.local που προφανώς δεν υπάρχει.

EDIT: Τώρα είδα όμως ότι στην δεύτερη προσπάθει όντως λέει ότι προσπαθεί over serial άρα μάλλον το έχεις όντως με καλώδιο. Εάν όντως μπορεί να φταίει ο κωδικός δοκίμασε να τον αλλάξεις σε κάτι τελείωε απλό στο yaml απλά για να δεις εάν το flasharisma τότε είναι επιτυχές ή πάλι τα ίδια. Επίσης βάζεις τον κωδικό μέσα σε ' ' ? 

Δηλαδή password: 'kati_edw'

19 ώρες πριν, Spect~ είπε

Δοκίμασες αλλο καλωδιο USB?

  Εμφάνιση κρυμμένου περιεχομένου

 The errno 71 "protocol error" usually means something went wrong at the USB link.

You can try looking in the kernel log (dmesg or "journalctl -k") to see if there are any USB-related kernel errors at the same time flashing failed.


You could try removing this and see if flashing works when powered from just USB (external power supply usually helps but may be injecting noise or trying to back-power the USB host port.)

You mentioned swapping USB cables but you could also try swapping USB ports, or using an external powered hub to connect to the ESP32.

It's also very possible the development board you have is faulty in some way.

 

Καλώδιο χρησιμοποιούσα ενα που εχω flashαρει πολλες φορές το tablet. 

Επειδή λοιπον δεν μπορούσα να βγάλω ακρη, τελικά κατεβασα το esphome flasher και το flashαρα μεσω pc/usb. Μετά του εκανα και ενα ΟΤΑ update με ΗΑ (μηπως και χρειαζόταν) και τελικά το είδε κανονικά.

 

Επόμενο βήμα.... τα θερμομετράκια.

 

ΥΓ: Σχετικά με το wifi pass, εχω πρόβλημα κάθε φορά που παω να συνδέσω συσκευή xiaomi (κυρίως extenders, όχι κινητά) γιατί η εφαρμογή αναφέρει ότι υπάρχουν μη αποδεκτοί χαρακτήρες στο pass. Για αυτό πηγε εκεί το μυαλό μου αρχικά

Επεξ/σία από fingolfingr
Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Και τελικά όλα πηγαν καλα. Πολύ βολικά αυτά τα θερμομετρακια και σε χαμηλή τιμή. Δεν ξερω για ακρίβεια βεβαιώ αλλα.... προσωπικά δεν με απασχολεί τόσο

image.png.512ae09a5d9be70100afc5cdbad529a0.png

Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
1 ώρα πριν, fingolfingr είπε

Eπειδή λοιπον δεν μπορούσα να βγάλω ακρη, τελικά κατεβασα το esphome flasher και το flashαρα μεσω pc/usb. Μετά του εκανα και ενα ΟΤΑ update με ΗΑ (μηπως και χρειαζόταν) και τελικά το είδε κανονικά.

Δεν έχω flasharei ποτε μέσω του ΗΑ απευθείας. Πάντοτε με το ESPHome flasher τα παιρνάω όλα την πρώτη φορά και μετά με ΟΤΑ ότι αλλαγές κάνω ;) 

Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
5 ώρες πριν, fingolfingr είπε

Και τελικά όλα πηγαν καλα. Πολύ βολικά αυτά τα θερμομετρακια και σε χαμηλή τιμή. Δεν ξερω για ακρίβεια βεβαιώ αλλα.... προσωπικά δεν με απασχολεί τόσο

image.png.512ae09a5d9be70100afc5cdbad529a0.png

Καλημέρα , 

Δηλαδή έχουν συνδεθεί και τα τρία θερμόμετρα πάνω σε ένα esp32??

Ή το κάθε θερμόμετρο σε ξεχωριστό esp32??

Αν όλα σε ένα,,  από κάλυψη πως είσαι;;;;

Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
Δημοσ. (επεξεργασμένο)
59 λεπτά πριν, lambros είπε

Καλημέρα , 

Δηλαδή έχουν συνδεθεί και τα τρία θερμόμετρα πάνω σε ένα esp32??

Ή το κάθε θερμόμετρο σε ξεχωριστό esp32??

Αν όλα σε ένα,,  από κάλυψη πως είσαι;;;;

Προς το παρόν έβαλα μόνο το ένα. Αλλά από ότι βλέπω στο video μπορούν να μπουν όλα στο ίδιο. 

 

Κάλυψη... δεν μπορώ να σου πω ακόμα. Το θερμόμετρα κι όμως με το original firmware συνδεόταν με το κινητο όταν εγώ ήμουν στον 3ο και αυτό στον 1ο. Οπότε λογικά δεν υπάρχει θέμα.

6 ώρες πριν, than2031995 είπε

Δεν έχω flasharei ποτε μέσω του ΗΑ απευθείας. Πάντοτε με το ESPHome flasher τα παιρνάω όλα την πρώτη φορά και μετά με ΟΤΑ ότι αλλαγές κάνω ;) 

1η φορά flashαρα esp οπότε.... live and learn. Πάντως ήταν πολύ εύκολη η διαδικασία μέσω flasher.

Επεξ/σία από fingolfingr
Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
  • 2 εβδομάδες αργότερα...
Δημοσ. (επεξεργασμένο)

Καμία ιδέα γιατί υπάρχουν στιγμές που δεν παίζουν κάποιοι αυτοματισμοί; Ανάβω το φως αυτόματα πχ. με αισθητήρα κίνησης και μία στις 10 δεν παίζει, ενώ βλέπω μέσα στο ΗΑ ότι ο αισθητήρας κίνησης ανιχνεύει κίνηση.

Ο διακόπτης είναι sonoff wifi και γενικά το lan μου είναι ισχυρό με ubiquiti ap και edgerouter.

Επεξ/σία από AgMa
Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
Στις 3/5/2021 στις 5:31 ΜΜ, AgMa είπε

Καμία ιδέα γιατί υπάρχουν στιγμές που δεν παίζουν κάποιοι αυτοματισμοί; Ανάβω το φως αυτόματα πχ. με αισθητήρα κίνησης και μία στις 10 δεν παίζει, ενώ βλέπω μέσα στο ΗΑ ότι ο αισθητήρας κίνησης ανιχνεύει κίνηση.

Ο διακόπτης είναι sonoff wifi και γενικά το lan μου είναι ισχυρό με ubiquiti ap και edgerouter.

Όταν συμβαίνει αυτό, δηλαδή εάν βλέπεις ότι ο αισθητήρας σου ανίχνευσε κίνηση, πήγαινε στον αυτοματισμό και δες εάν υπάρχει trace (το μεσαίο εικονίδιο) να δεις εάν για κάποιο λόγο κάτι τον σταματάει. 

Άλλοι λόγοι μπορεί να είναι το HA το ίδιο να τρέχει πολλά πράγματα ταυτόχρονα (υπερβολικά υψηλή CPU/RAM), το database σου να είναι αργό εάν έχεις πολλά entities/state changes κτλπ). 

Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
1 ώρα πριν, than2031995 είπε

Όταν συμβαίνει αυτό, δηλαδή εάν βλέπεις ότι ο αισθητήρας σου ανίχνευσε κίνηση, πήγαινε στον αυτοματισμό και δες εάν υπάρχει trace (το μεσαίο εικονίδιο) να δεις εάν για κάποιο λόγο κάτι τον σταματάει. 

Άλλοι λόγοι μπορεί να είναι το HA το ίδιο να τρέχει πολλά πράγματα ταυτόχρονα (υπερβολικά υψηλή CPU/RAM), το database σου να είναι αργό εάν έχεις πολλά entities/state changes κτλπ). 

Όχι, trace δεν υπάρχει. Τρέχει σε rpi 4 με ssd. Δικαιολογείται να λαγκάρει;

Screenshot_20210507_000548_io.homeassistant.companion.android.jpg

Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
7 ώρες πριν, AgMa είπε

Όχι, trace δεν υπάρχει. Τρέχει σε rpi 4 με ssd. Δικαιολογείται να λαγκάρει;

Screenshot_20210507_000548_io.homeassistant.companion.android.jpg

Δεν ξέρω αν έχει κάποια σχέση, αλλά τι σου τρώει τόση μνήμη;

Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
20 ώρες πριν, AgMa είπε

Όχι, trace δεν υπάρχει. Τρέχει σε rpi 4 με ssd. Δικαιολογείται να λαγκάρει;

Screenshot_20210507_000548_io.homeassistant.companion.android.jpg

Τότε όχι. Δεν θα έπρεπε. Ειδικά με SSD. Παρόλαυτα ανεξάρτητα δες για MariaDB για database εχει καλύτερη απόκρηση

Όσο για το trace κάτι με το trigger σου θα φταίει μάλλον. Πως είναι ο αυτοματιμσός σου; 

 

Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
17 ώρες πριν, mechpanos είπε

Δεν ξέρω αν έχει κάποια σχέση, αλλά τι σου τρώει τόση μνήμη;

Το headless debian. Παλιότερα ήμουν σε vm και ήταν καλύτερα, αλλά θορυβήθηκα με το "not supported" και είπα να πάω σε κάτι πιο "supported".

5 ώρες πριν, than2031995 είπε

Τότε όχι. Δεν θα έπρεπε. Ειδικά με SSD. Παρόλαυτα ανεξάρτητα δες για MariaDB για database εχει καλύτερη απόκρηση

Όσο για το trace κάτι με το trigger σου θα φταίει μάλλον. Πως είναι ο αυτοματιμσός σου; 

 

Τίποτα το ιδιαίτερο (συγχωρέστε με για το φορμάτ του κώδικα αλλά είμαι απ'το κινητό):

- alias: Αυτόματο φως μπάνιου on
  trigger:
    platform: state
    entity_id: binary_sensor.motion_sensor_philips_mpanio
    to: 'on'
  condition:
  - condition: state
    entity_id: switch.toualeta
    state: 'off'
  - condition: numeric_state
    entity_id: sensor.lumi_xiaomi_motion_sensor_mpanio
    below: 10
  action:
    service: switch.turn_on
    entity_id: switch.toualeta

Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
5 ώρες πριν, AgMa είπε

Το headless debian. Παλιότερα ήμουν σε vm και ήταν καλύτερα, αλλά θορυβήθηκα με το "not supported" και είπα να πάω σε κάτι πιο "supported".

Τίποτα το ιδιαίτερο (συγχωρέστε με για το φορμάτ του κώδικα αλλά είμαι απ'το κινητό):

- alias: Αυτόματο φως μπάνιου on
  trigger:
    platform: state
    entity_id: binary_sensor.motion_sensor_philips_mpanio
    to: 'on'
  condition:
  - condition: state
    entity_id: switch.toualeta
    state: 'off'
  - condition: numeric_state
    entity_id: sensor.lumi_xiaomi_motion_sensor_mpanio
    below: 10
  action:
    service: switch.turn_on
    entity_id: switch.toualeta

Για αρχη θα σου προτεινα να βγαλεις τα 2 condition, να το δουλεψεις μια δυο μερες ετσι. Μετα να προσθεσεις το ενα να το δουλεψεις αλλες δυο μερες και μετα να προσθεσεις και το δεύτερο.. Ετσι θα παρατηρήσεις τη συμπεριφορά του και θα δεις εαν προκαλείται απο κάποιο απο τα condition

  • Like 1
Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
15 ώρες πριν, AgMa είπε

Το headless debian. Παλιότερα ήμουν σε vm και ήταν καλύτερα, αλλά θορυβήθηκα με το "not supported" και είπα να πάω σε κάτι πιο "supported".

Μου φαίνεται υπερβολική η χρήση ram... Μήπως τρέχεις καμία βαριά database και κρατάει μεγάλο ιστορικό στη μνήμη...Δεν ξέρω...
Τώρα να ρίξω ιδέα να περάσεις κανένα real time kernel...ή θες να παραμείνεις supported και healthy :)

Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες
16 ώρες πριν, AgMa είπε

Το headless debian. Παλιότερα ήμουν σε vm και ήταν καλύτερα, αλλά θορυβήθηκα με το "not supported" και είπα να πάω σε κάτι πιο "supported".

To VM είναι supported. Βέβαια δεν θα έτρεχα VM σε Rpi. Έχεις τόσα άλλο πράγματα πάνω στο Pi που χρειάζεσαι το Debian και τρέχεις Supervised εντωμεταξύ;

10 ώρες πριν, Spect~ είπε

Για αρχη θα σου προτεινα να βγαλεις τα 2 condition, να το δουλεψεις μια δυο μερες ετσι. Μετα να προσθεσεις το ενα να το δουλεψεις αλλες δυο μερες και μετα να προσθεσεις και το δεύτερο.. Ετσι θα παρατηρήσεις τη συμπεριφορά του και θα δεις εαν προκαλείται απο κάποιο απο τα condition

Από την στιγμή που οι αυτοματισμοί είναι περασμένοι από το UI ή εάν είναι από το YAML χειροκίνητα και έχουν unique_id d δημιούργουνται traces τώρα πια. Το οποίο σημαίνει ότι δεν χρειάζεται να αφαιρείς conditions και να περιμένεις αν θα δουλέψει ή όχι. Πας στο trace (δεδομένου φυσικά ότι το trigger σου δουλεύει) και θα σου δείξει ότι πχ α ξεκίνησα τρίγκερ αλλά σταμάτησα στο 1ο ή στο 2ο condition καθώς δεν τηρεί τις προυποθέσεις που έχεις ορίσει.

image.png.d2710dfd42f85aa4496b86f4da2e8e4e.png

Σύνδεσμος στην ανάρτηση
Κοινοποίηση σε άλλες σελίδες

Δημιουργήστε ένα λογαριασμό ή συνδεθείτε για να σχολιάσετε

Πρέπει να είστε μέλος για να αφήσετε σχόλιο

Δημιουργία λογαριασμού

Εγγραφείτε με νέο λογαριασμό στην κοινότητα μας. Είναι πανεύκολο!

Εγγραφείτε για έναν νέο λογαριασμό

Σύνδεση

Έχετε ήδη λογαριασμό; Συνδεθείτε εδώ.

Συνδεθείτε τώρα

  • Δημιουργία νέου...

Με την περιήγησή σας στο insomnia.gr, αποδέχεστε τη χρήση cookies που ενισχύουν σημαντικά την εμπειρία χρήσης.